aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pybluez_0.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pybluez_0.23.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pybluez_0.23.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pybluez_0.23.bb b/meta-python/recipes-devtools/python/python3-pybluez_0.23.bb
index 5242059bc6..a38e10eec0 100644
--- a/meta-python/recipes-devtools/python/python3-pybluez_0.23.bb
+++ b/meta-python/recipes-devtools/python/python3-pybluez_0.23.bb
@@ -4,16 +4,23 @@ SECTION = "devel/python"
DEPENDS = "bluez5"
-LICENSE = "GPL-2.0"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=8a71d0475d08eee76d8b6d0c6dbec543"
+SRC_URI += "file://0001-Use-Py_ssize_t-when-parsing-buffer-length-fix-426-42.patch \
+ file://py-3.11.patch "
SRC_URI[md5sum] = "afbe8429bb82d2c46a3d0f5f4f898f9d"
SRC_URI[sha256sum] = "c8f04d2e78951eaa9de486b4d49381704e8943d0a6e6e58f55fcd7b8582e90de"
PYPI_PACKAGE = "PyBluez"
+
inherit pypi setuptools3
-RDEPENDS_${PN} += "\
+do_configure:prepend() {
+ sed -i -e "/use_2to3=True,/d" ${S}/setup.py
+}
+
+RDEPENDS:${PN} += "\
bluez5 \
- ${PYTHON_PN}-fcntl \
+ python3-fcntl \
"