aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb b/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb
index 7a873a1e12..47a40fdce2 100644
--- a/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb
@@ -10,7 +10,7 @@ inherit pypi setuptools3 python3-dir
DEPENDS += "${PYTHON_PN}-pytest-runner-native"
-do_install_append(){
+do_install:append(){
rm ${D}${bindir}/pylint
cat >> ${D}${bindir}/pylint <<EOF
#!/usr/bin/env ${PYTHON_PN}
@@ -22,12 +22,12 @@ EOF
}
PACKAGES =+ "${PN}-tests"
-FILES_${PN}-tests+= " \
+FILES:${PN}-tests+= " \
${PYTHON_SITEPACKAGES_DIR}/pylint/test/ \
${PYTHON_SITEPACKAGES_DIR}/pylint/testutils.py \
"
-RDEPENDS_${PN} += "${PYTHON_PN}-astroid \
+RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
${PYTHON_PN}-isort \
${PYTHON_PN}-numbers \
${PYTHON_PN}-shell \