aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymisp_2.4.190.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymisp_2.4.190.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.190.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.190.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.190.bb
new file mode 100644
index 0000000000..c1389982d4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.190.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Python API for MISP"
+HOMEPAGE = "https://github.com/MISP/PyMISP"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
+
+SRC_URI[sha256sum] = "e7374295bfd8c7d25f56867e4395a029433360d95420e39b7f78eb1d4f8b48b4"
+
+inherit python_poetry_core pypi
+
+RDEPENDS:${PN} += " \
+ python3-dateutil \
+ python3-json \
+ python3-jsonschema \
+ python3-requests \
+ python3-six \
+ python3-deprecated \
+ python3-wrapt \
+"
+
+# Fixes: python3-pymisp requires /bin/bash, but no
+# providers found in RDEPENDS:python3-pymisp? [file-rdep]
+RDEPENDS:${PN} += "bash"