aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb22
1 files changed, 15 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb b/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
index 6e53461979..a2f2ab4df4 100644
--- a/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
@@ -11,13 +11,7 @@ PYPI_PACKAGE = "PyNaCl"
inherit pypi python_setuptools_build_meta
DEPENDS += "\
- ${PYTHON_PN}-cffi-native \
- libsodium \
-"
-
-RDEPENDS:${PN} = "\
- ${PYTHON_PN}-six \
- ${PYTHON_PN}-cffi \
+ python3-cffi-native \
libsodium \
"
@@ -28,3 +22,17 @@ do_compile:prepend() {
do_install:prepend() {
export SODIUM_INSTALL=system
}
+
+RDEPENDS:${PN} = "\
+ python3-six \
+ python3-cffi \
+ libsodium \
+"
+
+RPROVIDES:${PN} = "python3-nacl"
+
+# in meta-virtualization layer
+#
+RCONFLICTS:${PN} = "python3-nacl"
+
+BBCLASSEXTEND = "native nativesdk"