aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyserial_3.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyserial_3.5.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb b/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
index 4766d92266..ade137a385 100644
--- a/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
@@ -9,6 +9,7 @@ inherit pypi setuptools3 ptest
do_install:append() {
rm -f ${D}${bindir}/pyserial-miniterm
rm -f ${D}${bindir}/pyserial-ports
+ rm -rf ${D}${bindir}/__pycache__
rmdir ${D}${bindir}
}
@@ -36,14 +37,14 @@ FILES:${PN}-win32 = " \
"
RDEPENDS:${PN} = "\
- ${PYTHON_PN}-fcntl \
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-logging \
- ${PYTHON_PN}-netclient \
- ${PYTHON_PN}-numbers \
- ${PYTHON_PN}-shell \
- ${PYTHON_PN}-stringold \
- ${PYTHON_PN}-threading \
+ python3-fcntl \
+ python3-io \
+ python3-logging \
+ python3-netclient \
+ python3-numbers \
+ python3-shell \
+ python3-stringold \
+ python3-threading \
"
BBCLASSEXTEND = "native nativesdk"
@@ -53,7 +54,8 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {