aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-rarfile_4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-rarfile_4.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-rarfile_4.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rarfile_4.2.bb b/meta-python/recipes-devtools/python/python3-rarfile_4.2.bb
new file mode 100644
index 0000000000..41cff4bfc4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rarfile_4.2.bb
@@ -0,0 +1,23 @@
+SUMMARY = "RAR archive reader for Python"
+HOMEPAGE = "https://github.com/markokr/rarfile"
+LICENSE = "ISC"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1916695551f7eec48dfd97db9467b831"
+
+inherit setuptools3
+
+SRC_URI[sha256sum] = "8e1c8e72d0845ad2b32a47ab11a719bc2e41165ec101fd4d3fe9e92aa3f469ef"
+
+inherit pypi
+
+PYPI_PACKAGE="rarfile"
+
+RDEPENDS:${PN} += "\
+ p7zip \
+ python3-core \
+ python3-datetime \
+ python3-crypt \
+ python3-io \
+"
+
+BBCLASSEXTEND = "native nativesdk"