aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-web3_6.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-web3_6.16.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-web3_6.16.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-web3_6.16.0.bb b/meta-python/recipes-devtools/python/python3-web3_6.16.0.bb
new file mode 100644
index 0000000000..01738f22c5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-web3_6.16.0.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A Python library for interacting with Ethereum."
+HOMEPAGE = "https://github.com/ethereum/web3.py"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=373fede350846fdffd23648fba504635"
+
+SRC_URI[sha256sum] = "b10c93476c106acc44b8428e47c61c385b7d0885e82cdc24049d27f521833552"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-aiohttp \
+ python3-eth-abi \
+ python3-eth-account \
+ python3-eth-hash \
+ python3-eth-typing \
+ python3-eth-utils \
+ python3-hexbytes \
+ python3-jsonschema \
+ python3-protobuf \
+ python3-pydantic \
+ python3-requests \
+ python3-typing-extensions \
+ python3-websockets \
+ python3-pyunormalize \
+"