aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-pyparted
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-pyparted')
-rw-r--r--meta-python/recipes-extended/python-pyparted/python3-pyparted_3.12.0.bb (renamed from meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb)16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.12.0.bb
index 8909aa11f4..7a0d3987d2 100644
--- a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb
+++ b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.12.0.bb
@@ -3,23 +3,25 @@ an interface to libparted, the GNU parted library for disk partitioning and \
filesystem manipulation."
SUMMARY = "Python bindings for libparted"
HOMEPAGE = "https://github.com/rhinstaller/pyparted"
-LICENSE = "GPL-2.0+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "\
file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \
"
-SRC_URI[md5sum] = "69284f943982f54ded76960c92098a02"
-SRC_URI[sha256sum] = "61cde7b096bccd69ddc75c85b17f8baed45c3687d404706d91403a319453b903"
+SRC_URI[sha256sum] = "da985e116beb733371feb605b174db9eec8bd0eedffc8f739f8e603f51b521e7"
-inherit pypi distutils3
+inherit pkgconfig pypi setuptools3
DEPENDS += "parted"
-RDEPENDS_${PN}_class-target += " \
+RDEPENDS:${PN}:class-target += " \
parted (>= 2.3) \
- python3-stringold python3-codecs python3-math \
+ python3-codecs \
+ python3-math \
+ python3-numbers \
+ python3-stringold \
"
-RDEPENDS_${PN}_class-native = ""
+RDEPENDS:${PN}:class-native = ""
BBCLASSEXTEND = "native"