aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-25 02:20:50 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:45:40 +0100
commit5f62e834ae4bed4c81b8a57c7930d7822cccdb96 (patch)
tree9b811a411cf18d3edafc25a0fbc302a7d343d5ec
parent65d891bd2eaaa38b8f302f33fdf8eee3d39b67c0 (diff)
downloadmeta-opie-5f62e834ae4bed4c81b8a57c7930d7822cccdb96.tar.gz
Add LIC_FILES_CHKSUM to many recipes
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--recipes-opie/images/opie-image-16mb.bb2
-rw-r--r--recipes-opie/images/opie-image.bb2
-rw-r--r--recipes-opie/opie-ttf-support/opie-ttf-support_1.1.bb2
-rw-r--r--recipes-opie/tasks/task-opie-16mb.bb2
-rw-r--r--recipes-opie/tasks/task-opie-all.bb2
-rw-r--r--recipes-opie/tasks/task-opie-apps.bb2
-rw-r--r--recipes-opie/tasks/task-opie-games.bb2
-rw-r--r--recipes-opie/tasks/task-opie.bb2
-rw-r--r--recipes-opie/tasks/task-xqtlauncher.bb2
-rw-r--r--recipes-qt/qmake/qmake-native_1.07a.bb3
-rw-r--r--recipes-qt/qte/qte-common_2.3.10.inc2
-rw-r--r--recipes-qt/uicmoc/uicmoc-native_2.3.10.bb3
-rw-r--r--recipes-qtopia/portabase/metakit_2.4.9.3.bb2
-rw-r--r--recipes-qtopia/portabase/portabase_1.9.bb3
-rw-r--r--recipes-support/libetpan/libetpan_0.57.bb3
-rw-r--r--recipes-support/obexftp/obexftp_0.23.bb3
-rw-r--r--recipes-support/obexpush/obexpush_1.0.0.bb2
17 files changed, 39 insertions, 0 deletions
diff --git a/recipes-opie/images/opie-image-16mb.bb b/recipes-opie/images/opie-image-16mb.bb
index 8569e95..8f706aa 100644
--- a/recipes-opie/images/opie-image-16mb.bb
+++ b/recipes-opie/images/opie-image-16mb.bb
@@ -1,3 +1,5 @@
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
IMAGE_LINGUAS = ""
DEPENDS = "task-boot task-opie-16mb"
diff --git a/recipes-opie/images/opie-image.bb b/recipes-opie/images/opie-image.bb
index 4a984a0..67ace80 100644
--- a/recipes-opie/images/opie-image.bb
+++ b/recipes-opie/images/opie-image.bb
@@ -1,3 +1,5 @@
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
IMAGE_LINGUAS = ""
DEPENDS = "task-base task-opie"
diff --git a/recipes-opie/opie-ttf-support/opie-ttf-support_1.1.bb b/recipes-opie/opie-ttf-support/opie-ttf-support_1.1.bb
index c075fef..fcfaf84 100644
--- a/recipes-opie/opie-ttf-support/opie-ttf-support_1.1.bb
+++ b/recipes-opie/opie-ttf-support/opie-ttf-support_1.1.bb
@@ -8,6 +8,8 @@ SRC_URI = "file://update-qtttffontdir.c \
file://02qtttffont-update"
S = "${WORKDIR}"
+LIC_FILES_CHKSUM = "file://update-qtttffontdir.c;beginline=4;endline=7;md5=84d4335f8f9e85774e2a15b2dff91401"
+
do_compile() {
${CC} ${CFLAGS} ${LDFLAGS} -I${STAGING_INCDIR}/freetype2 -lfreetype -o update-qtttffontdir update-qtttffontdir.c
}
diff --git a/recipes-opie/tasks/task-opie-16mb.bb b/recipes-opie/tasks/task-opie-16mb.bb
index 859a0f5..42ed6a4 100644
--- a/recipes-opie/tasks/task-opie-16mb.bb
+++ b/recipes-opie/tasks/task-opie-16mb.bb
@@ -5,6 +5,8 @@ PR = "r3"
inherit task
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
PACKAGES = "task-opie-16mb-base \
task-opie-16mb-applets \
task-opie-16mb-inputmethods \
diff --git a/recipes-opie/tasks/task-opie-all.bb b/recipes-opie/tasks/task-opie-all.bb
index 899bd0b..3f3a33b 100644
--- a/recipes-opie/tasks/task-opie-all.bb
+++ b/recipes-opie/tasks/task-opie-all.bb
@@ -5,6 +5,8 @@ PR = "r3"
inherit task
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
PACKAGES = "task-opie-applets task-opie-inputmethods task-opie-styles \
task-opie-decorations task-opie-multimedia task-opie-wlan \
task-opie-settings task-opie-pim task-opie-datebookplugins \
diff --git a/recipes-opie/tasks/task-opie-apps.bb b/recipes-opie/tasks/task-opie-apps.bb
index f791c21..8015867 100644
--- a/recipes-opie/tasks/task-opie-apps.bb
+++ b/recipes-opie/tasks/task-opie-apps.bb
@@ -4,6 +4,8 @@ LICENSE = "MIT"
inherit task
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
PACKAGES = "task-opie-apps task-opie-extra-apps"
RDEPENDS_task-opie-apps = "opie-advancedfm opie-bartender opie-calculator \
diff --git a/recipes-opie/tasks/task-opie-games.bb b/recipes-opie/tasks/task-opie-games.bb
index dded235..0193532 100644
--- a/recipes-opie/tasks/task-opie-games.bb
+++ b/recipes-opie/tasks/task-opie-games.bb
@@ -5,6 +5,8 @@ PR = "r1"
inherit task
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
PACKAGES = "task-opie-games task-opie-extra-games"
RDEPENDS_task-opie-games = "opie-backgammon opie-bounce opie-buzzword opie-fifteen \
diff --git a/recipes-opie/tasks/task-opie.bb b/recipes-opie/tasks/task-opie.bb
index ec5910f..ec9e7f6 100644
--- a/recipes-opie/tasks/task-opie.bb
+++ b/recipes-opie/tasks/task-opie.bb
@@ -6,6 +6,8 @@ PR = "r14"
inherit task
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
PROVIDES = "task-opie-everything"
PACKAGES = "task-opie-base \
diff --git a/recipes-opie/tasks/task-xqtlauncher.bb b/recipes-opie/tasks/task-xqtlauncher.bb
index 15edf56..242307f 100644
--- a/recipes-opie/tasks/task-xqtlauncher.bb
+++ b/recipes-opie/tasks/task-xqtlauncher.bb
@@ -5,6 +5,8 @@ PR = "r1"
inherit task
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
PACKAGES = "task-xqtlauncher task-xqtlauncher-blackbox"
#xkbd is currently needed becuse of a bug at xqt2
diff --git a/recipes-qt/qmake/qmake-native_1.07a.bb b/recipes-qt/qmake/qmake-native_1.07a.bb
index 61ad118..5f86993 100644
--- a/recipes-qt/qmake/qmake-native_1.07a.bb
+++ b/recipes-qt/qmake/qmake-native_1.07a.bb
@@ -11,6 +11,9 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/${QTEVER}.tar.bz2 \
file://linux-oe-qmake.conf"
S = "${WORKDIR}/${QTEVER}"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=629178675a7d49c9fa19dfe9f43ea256 \
+ file://README;beginline=1;endline=7;md5=a85582a7befb26735438461afd8559af"
+
inherit autotools native
export QTDIR = "${S}"
diff --git a/recipes-qt/qte/qte-common_2.3.10.inc b/recipes-qt/qte/qte-common_2.3.10.inc
index 75419ac..25b69d3 100644
--- a/recipes-qt/qte/qte-common_2.3.10.inc
+++ b/recipes-qt/qte/qte-common_2.3.10.inc
@@ -69,6 +69,8 @@ W100_ACCEL_PATCHES = "file://c7x0-w100-accel.patch \
# universally.
#SRC_URI_append = "file://ipaq_sound_fix.patch "
+LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=aea7d119b7f7d798464fa2b1aae005f8 \
+ file://README;beginline=1;endline=7;md5=d3e237af71522cc2a3c89dbaf48b345d"
S = "${WORKDIR}/qt-${PV}"
export QTDIR = "${S}"
diff --git a/recipes-qt/uicmoc/uicmoc-native_2.3.10.bb b/recipes-qt/uicmoc/uicmoc-native_2.3.10.bb
index 12f10a0..0b46b85 100644
--- a/recipes-qt/uicmoc/uicmoc-native_2.3.10.bb
+++ b/recipes-qt/uicmoc/uicmoc-native_2.3.10.bb
@@ -14,6 +14,9 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz \
file://kernel-asm-page.patch"
S = "${WORKDIR}/qt-${PV}"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=aea7d119b7f7d798464fa2b1aae005f8 \
+ file://README;beginline=1;endline=7;md5=d3e237af71522cc2a3c89dbaf48b345d"
+
inherit native qmake_base
export QTDIR = "${S}"
diff --git a/recipes-qtopia/portabase/metakit_2.4.9.3.bb b/recipes-qtopia/portabase/metakit_2.4.9.3.bb
index 4634ac5..e77e093 100644
--- a/recipes-qtopia/portabase/metakit_2.4.9.3.bb
+++ b/recipes-qtopia/portabase/metakit_2.4.9.3.bb
@@ -10,6 +10,8 @@ SRC_URI = "http://www.equi4.com/pub/mk/metakit-${PV}.tar.gz \
file://metakit-2.4.9.3.patch"
PR = "r3"
+LIC_FILES_CHKSUM = "file://README;beginline=128;endline=151;md5=de6cb08350982d56e0349fd5acb35621"
+
FILES_${PN} += " ${libdir}/*.so"
do_configure_prepend() {
diff --git a/recipes-qtopia/portabase/portabase_1.9.bb b/recipes-qtopia/portabase/portabase_1.9.bb
index 6c08432..2cdce76 100644
--- a/recipes-qtopia/portabase/portabase_1.9.bb
+++ b/recipes-qtopia/portabase/portabase_1.9.bb
@@ -15,6 +15,9 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/portabase/portabase_${PV}.tar.gz \
S = "${WORKDIR}/portabase"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d0dd973fa1720a3bd3265926fb19675 \
+ file://main.cpp;beginline=1;endline=9;md5=5ac88094cf0e596136cd701f80c5ebb4"
+
inherit palmtop
do_configure_prepend() {
diff --git a/recipes-support/libetpan/libetpan_0.57.bb b/recipes-support/libetpan/libetpan_0.57.bb
index c2661bd..bb22410 100644
--- a/recipes-support/libetpan/libetpan_0.57.bb
+++ b/recipes-support/libetpan/libetpan_0.57.bb
@@ -12,6 +12,9 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
inherit autotools pkgconfig gettext binconfig
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=f18ebe7e452708c26f83954f81062ba7 \
+ file://src/engine/mailengine.c;beginline=7;endline=29;md5=2cb1057a004588965254de2eee0b15a6"
+
EXTRA_OECONF = "--without-openssl --with-gnutls --disable-db"
PARALLEL_MAKE = ""
diff --git a/recipes-support/obexftp/obexftp_0.23.bb b/recipes-support/obexftp/obexftp_0.23.bb
index ec9bc25..46cc628 100644
--- a/recipes-support/obexftp/obexftp_0.23.bb
+++ b/recipes-support/obexftp/obexftp_0.23.bb
@@ -8,6 +8,9 @@ PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/obexftp-${PV}.tar.bz2 \
"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ file://obexftp/obexftp_io.c;beginline=8;endline=19;md5=eaffa3b561e1a0f240e4277a6a2f1e66"
+
inherit autotools
EXTRA_OECONF += "--enable-bluetooth \
diff --git a/recipes-support/obexpush/obexpush_1.0.0.bb b/recipes-support/obexpush/obexpush_1.0.0.bb
index f0c1b97..786ecdb 100644
--- a/recipes-support/obexpush/obexpush_1.0.0.bb
+++ b/recipes-support/obexpush/obexpush_1.0.0.bb
@@ -11,6 +11,8 @@ SRC_URI = "http://www.caside.lancs.ac.uk/bt/obexpush.tar.gz \
file://opd_args"
S = "${WORKDIR}/obexpush"
+LIC_FILES_CHKSUM = "file://opd/main.c;beginline=16;endline=29;md5=0c9407c30554ca893bffa8bb82396f1e"
+
inherit update-rc.d
INITSCRIPT_NAME = "opd"