aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-light-and-power
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-light-and-power
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-light-and-power')
-rw-r--r--recipes-opie/opie-light-and-power/opie-light-and-power.inc17
-rw-r--r--recipes-opie/opie-light-and-power/opie-light-and-power_1.2.5.bb11
-rw-r--r--recipes-opie/opie-light-and-power/opie-light-and-power_cvs.bb7
3 files changed, 35 insertions, 0 deletions
diff --git a/recipes-opie/opie-light-and-power/opie-light-and-power.inc b/recipes-opie/opie-light-and-power/opie-light-and-power.inc
new file mode 100644
index 0000000..0d68d5f
--- /dev/null
+++ b/recipes-opie/opie-light-and-power/opie-light-and-power.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "Light and Power settings dialog"
+SECTION = "opie/settings"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "light-and-power"
+
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+# FILES plugins/application/liblight-and-power.so* bin/light-and-power apps/Settings/light.desktop pics/lightandpower
+do_install() {
+ install -d ${D}${palmtopdir}/pics/lightandpower/
+ install -m 0644 ${WORKDIR}/pics/lightandpower/*.png ${D}${palmtopdir}/pics/lightandpower/
+}
+
diff --git a/recipes-opie/opie-light-and-power/opie-light-and-power_1.2.5.bb b/recipes-opie/opie-light-and-power/opie-light-and-power_1.2.5.bb
new file mode 100644
index 0000000..f01ae49
--- /dev/null
+++ b/recipes-opie/opie-light-and-power/opie-light-and-power_1.2.5.bb
@@ -0,0 +1,11 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_settings_light-and-power.tar.bz2;name=split_core_settings_light-and-power \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_core_settings_light-and-power.md5sum] = "015b4d171bf91894d8b1fa6679979eee"
+SRC_URI[split_core_settings_light-and-power.sha256sum] = "d493018c5b5db81c29585965371402f2d1def7cd7fdcd0bd7a9ccac6ac68d373"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-light-and-power/opie-light-and-power_cvs.bb b/recipes-opie/opie-light-and-power/opie-light-and-power_cvs.bb
new file mode 100644
index 0000000..cc24b80
--- /dev/null
+++ b/recipes-opie/opie-light-and-power/opie-light-and-power_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/settings/light-and-power \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps"