aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-systemtime
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-systemtime
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-systemtime')
-rw-r--r--recipes-opie/opie-systemtime/opie-systemtime.inc22
-rw-r--r--recipes-opie/opie-systemtime/opie-systemtime_1.2.5.bb14
-rw-r--r--recipes-opie/opie-systemtime/opie-systemtime_cvs.bb8
3 files changed, 44 insertions, 0 deletions
diff --git a/recipes-opie/opie-systemtime/opie-systemtime.inc b/recipes-opie/opie-systemtime/opie-systemtime.inc
new file mode 100644
index 0000000..e91d971
--- /dev/null
+++ b/recipes-opie/opie-systemtime/opie-systemtime.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "Set the system time - utilizing ntpdate, if available."
+SECTION = "opie/settings"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RRECOMMENDS_${PN} = "ntpdate"
+
+APPNAME = "systemtime"
+
+
+S = "${WORKDIR}/netsystemtime"
+
+inherit opie
+
+# FILES plugins/application/libsystemtime.so* bin/systemtime apps/Settings/systemtime.desktop etc/ntpservers pics/netsystemtime
+do_install() {
+ install -d ${D}${palmtopdir}/pics/netsystemtime/
+ install -d ${D}${palmtopdir}/etc
+ install -m 0644 ${WORKDIR}/pics/netsystemtime/*.png ${D}${palmtopdir}/pics/netsystemtime/
+ install -m 0644 ${WORKDIR}/etc/ntpservers ${D}${palmtopdir}/etc
+}
+
+FILES_opie-systemtime_append = " /etc/ntpservers"
diff --git a/recipes-opie/opie-systemtime/opie-systemtime_1.2.5.bb b/recipes-opie/opie-systemtime/opie-systemtime_1.2.5.bb
new file mode 100644
index 0000000..f131f8e
--- /dev/null
+++ b/recipes-opie/opie-systemtime/opie-systemtime_1.2.5.bb
@@ -0,0 +1,14 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_noncore_settings_netsystemtime.tar.bz2;name=split_noncore_settings_netsystemtime \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ http://sources.openembedded.org/opie-1.2.5-split_etc.tar.bz2;name=split_etc \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_noncore_settings_netsystemtime.md5sum] = "bbfa0a8f09ad0bb657295084a316877d"
+SRC_URI[split_noncore_settings_netsystemtime.sha256sum] = "a603be217bd52eeb7b032c362e01e3c70d6dd71edab97fec8b761c1505ee78ab"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
+SRC_URI[split_etc.md5sum] = "74ef523ef12e242155bbb745072434d9"
+SRC_URI[split_etc.sha256sum] = "eef55ea2248b4f45f3a07beb6012e431dd71d4eefa134d39cc50b4d194c53087"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-systemtime/opie-systemtime_cvs.bb b/recipes-opie/opie-systemtime/opie-systemtime_cvs.bb
new file mode 100644
index 0000000..9a65f01
--- /dev/null
+++ b/recipes-opie/opie-systemtime/opie-systemtime_cvs.bb
@@ -0,0 +1,8 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/settings/netsystemtime \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=etc \
+ ${OPIE_GIT};protocol=git;subpath=apps"