aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/notez
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/notez
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/notez')
-rw-r--r--recipes-qtopia/notez/notez-1.1.0/fix-encoding.patch18
-rw-r--r--recipes-qtopia/notez/notez-1.1.0/use-homedir.patch92
-rw-r--r--recipes-qtopia/notez/notez_1.1.0.bb25
3 files changed, 135 insertions, 0 deletions
diff --git a/recipes-qtopia/notez/notez-1.1.0/fix-encoding.patch b/recipes-qtopia/notez/notez-1.1.0/fix-encoding.patch
new file mode 100644
index 0000000..54e809b
--- /dev/null
+++ b/recipes-qtopia/notez/notez-1.1.0/fix-encoding.patch
@@ -0,0 +1,18 @@
+--- notez-1.1.0/editWindow.cpp.orig 2002-11-17 17:40:08 +0100
++++ notez-1.1.0/editWindow.cpp 2004-12-22 14:02:13 +0100
+@@ -32,6 +32,7 @@
+ } else {
+
+ QTextStream inStream(&datei);
++ inStream.setEncoding(QTextStream::UnicodeUTF8);
+ editArea->setText(inStream.read());
+ datei.close();
+
+@@ -53,6 +54,7 @@
+ } else {
+
+ QTextStream outStream(&datei);
++ outStream.setEncoding(QTextStream::UnicodeUTF8);
+ outStream << editArea->text();
+ datei.close();
+ this->accept();
diff --git a/recipes-qtopia/notez/notez-1.1.0/use-homedir.patch b/recipes-qtopia/notez/notez-1.1.0/use-homedir.patch
new file mode 100644
index 0000000..375b154
--- /dev/null
+++ b/recipes-qtopia/notez/notez-1.1.0/use-homedir.patch
@@ -0,0 +1,92 @@
+--- notez-1.1.0/mainWindow.cpp.orig 2002-11-17 19:43:34 +0100
++++ notez-1.1.0/mainWindow.cpp 2004-11-21 22:55:06 +0100
+@@ -7,11 +7,11 @@
+
+ // check if the directory plain exists, if not
+ // create it
+- QString d1("Documents/text");
++ QString d1(QDir::homeDirPath() + "/Documents/text");
+ QDir pd1(d1);
+ if (!pd1.exists())
+ {
+- QDir pd1("Documents");
++ QDir pd1(QDir::homeDirPath() + "/Documents");
+ if (!pd1.mkdir("text", FALSE))
+ {
+ QMessageBox::critical( 0, "noteZ",
+@@ -22,11 +22,11 @@
+ }
+ }
+
+- QString d2("Documents/text/plain");
++ QString d2(QDir::homeDirPath() + "/Documents/text/plain");
+ QDir pd2(d2);
+ if (!pd2.exists())
+ {
+- QDir pd2("Documents/text");
++ QDir pd2(QDir::homeDirPath() + "/Documents/text");
+ if (!pd2.mkdir("plain", FALSE))
+ {
+ QMessageBox::critical( 0, "noteZ",
+@@ -40,14 +40,14 @@
+
+ unsigned int item, convertCount = 0;
+ QString strippedName;
+- QDir moveDir("Documents/text");
++ QDir moveDir(QDir::homeDirPath() + "/Documents/text");
+ moveDir.setFilter(QDir::Files);
+ moveDir.setNameFilter("[0-9]*-[0-9]*-[0-9]*-[0-9]*-[0-9]*-[0-9]*.txt");
+
+ for (item = 0; item < moveDir.count(); item++) {
+ strippedName = moveDir[item].left(moveDir[item].find("."));
+- QFile oldFile("Documents/text/" + moveDir[item]);
+- QFile newFile("Documents/text/plain/" + strippedName + ".ntz");
++ QFile oldFile(QDir::homeDirPath() + "/Documents/text/" + moveDir[item]);
++ QFile newFile(QDir::homeDirPath() + "/Documents/text/plain/" + strippedName + ".ntz");
+ if (!oldFile.open(IO_ReadOnly))
+ QMessageBox::warning(0, "File i/o error", "Could not read\nDocuments/text/" + moveDir[item] + "\nfor conversion.");
+
+@@ -104,7 +104,7 @@
+
+ case QMessageBox::Yes:
+ this->selected = notesList->currentItem();
+- QFile::remove("Documents/text/plain/" + fileList[notesList->currentItem()]);
++ QFile::remove(QDir::homeDirPath() + "/Documents/text/plain/" + fileList[notesList->currentItem()]);
+ refreshList(notesList);
+ break;
+
+@@ -146,7 +146,7 @@
+ QDate today(QDate::currentDate());
+ QTime now(QTime::currentTime());
+ QString name;
+- this->editFile(name.sprintf("Documents/text/plain/%4i-%02i-%02i-%02i-%02i-%02i.ntz", today.year(), today.month(), today.day(), now.hour(), now.minute(), now.second()),
++ this->editFile(name.sprintf(QDir::homeDirPath() + "/Documents/text/plain/%4i-%02i-%02i-%02i-%02i-%02i.ntz", today.year(), today.month(), today.day(), now.hour(), now.minute(), now.second()),
+ true );
+
+ }
+@@ -159,7 +159,7 @@
+ if( notesList->count() > 0 )
+ {
+ this->selected = number;
+- this->editFile("Documents/text/plain/" + fileList[number],
++ this->editFile(QDir::homeDirPath() + "/Documents/text/plain/" + fileList[number],
+ false);
+ }
+
+@@ -173,14 +173,14 @@
+
+ liste->clear();
+
+- fileList.setPath("Documents/text/plain/");
++ fileList.setPath(QDir::homeDirPath() + "/Documents/text/plain/");
+ fileList.setFilter(QDir::Files);
+ fileList.setSorting(QDir::Name);
+ fileList.setNameFilter("*.ntz");
+
+ for (item = 0; item < fileList.count(); item++) {
+
+- QFile datei("Documents/text/plain/" + fileList[item]);
++ QFile datei(QDir::homeDirPath() + "/Documents/text/plain/" + fileList[item]);
+
+ if (!datei.open(IO_ReadOnly)) {
+
diff --git a/recipes-qtopia/notez/notez_1.1.0.bb b/recipes-qtopia/notez/notez_1.1.0.bb
new file mode 100644
index 0000000..99fc83a
--- /dev/null
+++ b/recipes-qtopia/notez/notez_1.1.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "simple note-taking application"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Henning Holtschneider <hh@holtschneider.com>"
+HOMEPAGE = "http://www.holtschneider.com/notez/"
+APPNAME = "notez"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+PR = "r1"
+
+SRC_URI = "http://www.holtschneider.com/notez/notez-${PV}.tar.gz \
+file://use-homedir.patch \
+file://fix-encoding.patch"
+
+inherit opie
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 notez.png ${D}${palmtopdir}/pics/noteZ.png
+}
+
+
+SRC_URI[md5sum] = "c348a626fc09265fa74a12470c83c113"
+SRC_URI[sha256sum] = "11ee0a660faca7993a2f525d2964391d135b9552d9e94abad6cb6c5f3983f964"