aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/phalanx
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/phalanx
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/phalanx')
-rw-r--r--recipes-qtopia/phalanx/phalanx/capabilities18
-rw-r--r--recipes-qtopia/phalanx/phalanx/description10
-rw-r--r--recipes-qtopia/phalanx/phalanx_22.bb29
3 files changed, 57 insertions, 0 deletions
diff --git a/recipes-qtopia/phalanx/phalanx/capabilities b/recipes-qtopia/phalanx/phalanx/capabilities
new file mode 100644
index 0000000..703cf84
--- /dev/null
+++ b/recipes-qtopia/phalanx/phalanx/capabilities
@@ -0,0 +1,18 @@
+[GENERAL]
+NAME=Phalanx
+VERSION=0.1.2
+exec=phalanx
+cmd=-l- -P /opt/QtPalmtop/chess/engines/Phalanx -S /opt/QtPalmtop/chess/engines/Phalanx
+
+[CAPABILITIES]
+UNDO=1
+EDIT=1
+BOOK=1
+
+[DIFFICULTY]
+level_very_easy_cmd=-e 100
+level_easy_cmd=-e 75
+level_moderate_cmd=-e 42
+level_hard_cmd=-e 15
+level_very_hard_cmd=-e 0
+
diff --git a/recipes-qtopia/phalanx/phalanx/description b/recipes-qtopia/phalanx/phalanx/description
new file mode 100644
index 0000000..945d103
--- /dev/null
+++ b/recipes-qtopia/phalanx/phalanx/description
@@ -0,0 +1,10 @@
+<qt>
+<b>Phalanx</b>
+<hr>
+Phalanx chess engine was written by Dusan Dobes and it is one of the youngest of the
+free chess programs.
+Despite this fact it has managed to become quite strong approaching the level of some
+modern commercial chess software.
+<br>
+This engine supports differing difficulty levels
+</qt>
diff --git a/recipes-qtopia/phalanx/phalanx_22.bb b/recipes-qtopia/phalanx/phalanx_22.bb
new file mode 100644
index 0000000..b456a30
--- /dev/null
+++ b/recipes-qtopia/phalanx/phalanx_22.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Phalanx is a chess playing engine."
+SECTION = "opie/libs"
+PRIORITY = "optional"
+PR = "r5"
+LICENSE = "GPL"
+SRC_URI = "http://ftp.debian.org/debian/pool/main/p/phalanx/phalanx_22+d051004.orig.tar.gz \
+ file://capabilities \
+ file://description"
+S = "${WORKDIR}/Phalanx-XXII/"
+
+do_compile() {
+ oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" STRIP=echo LD="${CC}"
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/chess/engines/Phalanx
+ install -D -m 755 phalanx ${D}${palmtopdir}/chess/engines/Phalanx/phalanx
+ install -D -m 755 pbook.phalanx ${D}${palmtopdir}/chess/engines/Phalanx/pbook.phalanx
+ >${D}${palmtopdir}/chess/engines/Phalanx/sbook.phalanx
+ >${D}${palmtopdir}/chess/engines/Phalanx/learn.phalanx
+ install -D -m 755 ${WORKDIR}/capabilities ${D}${palmtopdir}/chess/engines/Phalanx/capabilities
+ install -D -m 755 ${WORKDIR}/description ${D}${palmtopdir}/chess/engines/Phalanx/description
+}
+
+FILES_${PN} = "${palmtopdir}/chess"
+FILES_${PN}-dbg += "${palmtopdir}/chess/engines/Phalanx/.debug"
+SRC_URI[md5sum] = "24657c063f5fda57e70130483bd45cd0"
+SRC_URI[sha256sum] = "1ec5e8e5f71e199963796462086a6e9a0d8856b7fd4b83324a30a35c25677082"
+