aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/qpdf2/qpdf2_2.2.1.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/qpdf2/qpdf2_2.2.1.bb
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/qpdf2/qpdf2_2.2.1.bb')
-rw-r--r--recipes-qtopia/qpdf2/qpdf2_2.2.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-qtopia/qpdf2/qpdf2_2.2.1.bb b/recipes-qtopia/qpdf2/qpdf2_2.2.1.bb
new file mode 100644
index 0000000..7232637
--- /dev/null
+++ b/recipes-qtopia/qpdf2/qpdf2_2.2.1.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "QPDF2 is a Viewer for PDF documents. An unnecessary fork based on opie-qpdf."
+PRIORITY = "optional"
+SECTION = "opie/applications"
+HOMEPAGE = "http://qpdf2.sf.net"
+LICENSE = "GPL"
+DEPENDS = "t1lib freetype"
+APPNAME = "qpdf"
+APPTYPE = "binary"
+APPDESKTOP = "${S}/ipkg-render-freetype/opt/QtPalmtop/apps/Applications"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf2/qpdf2_2.2.1_20040217b.tgz \
+ file://hack-the-hack.patch \
+ file://fix-sigsegv.patch \
+ file://fix_qtversion_check.patch \
+ file://gcc4.patch"
+S = "${WORKDIR}/qpdf2_${PV}"
+
+inherit opie
+
+QMAKE_PROFILES = "qpdf_render-freetype.pro"
+EXTRA_QMAKEVARS_POST += "TARGET=qpdf"
+export OE_QMAKE_LINK="${CXX}"
+
+do_configure_prepend() {
+ find . -name "Makefile"|xargs rm -f
+ find . -name "*.o"|xargs rm -f
+ find . -name "*.a"|xargs rm -f
+ find . -name "*.la"|xargs rm -f
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/qpdf
+ install -m 0644 ipkg-render-freetype/opt/QtPalmtop/pics/qpdf/*.* ${D}${palmtopdir}/pics/qpdf/
+}
+
+
+SRC_URI[md5sum] = "6b94eda9bd8e2b884c753d70fee04b3f"
+SRC_URI[sha256sum] = "3378f7a92f3afbc3663cce8c99790092282eb01101ba21aed4709736cf875ad5"