aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/shopper
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/shopper
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/shopper')
-rw-r--r--recipes-qtopia/shopper/shopper-1.2.1/gcc3.patch11
-rw-r--r--recipes-qtopia/shopper/shopper-1.2.1/path_fix.patch23
-rw-r--r--recipes-qtopia/shopper/shopper_1.2.1.bb39
3 files changed, 73 insertions, 0 deletions
diff --git a/recipes-qtopia/shopper/shopper-1.2.1/gcc3.patch b/recipes-qtopia/shopper/shopper-1.2.1/gcc3.patch
new file mode 100644
index 0000000..940b4ea
--- /dev/null
+++ b/recipes-qtopia/shopper/shopper-1.2.1/gcc3.patch
@@ -0,0 +1,11 @@
+--- Shopper/shoppingitem.h.orig 2004-03-07 12:02:51.087057272 +0000
++++ Shopper/shoppingitem.h 2004-03-07 12:03:09.285290720 +0000
+@@ -33,7 +33,7 @@
+
+ public:
+ ShoppingItemCheckBox (const QString & text, QWidget * parent,
+- const char * name=0 );
++ const char * name );
+ signals:
+ void edit();
+
diff --git a/recipes-qtopia/shopper/shopper-1.2.1/path_fix.patch b/recipes-qtopia/shopper/shopper-1.2.1/path_fix.patch
new file mode 100644
index 0000000..d8142c7
--- /dev/null
+++ b/recipes-qtopia/shopper/shopper-1.2.1/path_fix.patch
@@ -0,0 +1,23 @@
+--- Shopper/shoplist.cpp 2008-11-17 21:09:26.000000000 +0000
++++ Shopper/shoplist.cpp 2008-11-17 22:21:12.000000000 +0000
+@@ -38,6 +38,7 @@
+ #include <qmessagebox.h>
+ #include <qregexp.h>
+
++#include <stdlib.h>
+
+ // TODO: Somewhere it should say:
+ // if (mode == ShoppingItem::Left && nothing_left) {
+@@ -229,6 +230,12 @@
+ QString fileName = Global::applicationFileName("ShoppingListQt", "shoppinglist.xml");
+
+ QFile file( fileName );
++ if ( ! file.exists() ) {
++ // Ugly hack
++ QString cmd = QString("cp " SHOPPER_DATADIR "/shoppinglist.xml ") + fileName;
++ system(cmd);
++ }
++
+ _startCategory = static_cast<CategoryItem*>(_showAllAction);
+ // If there's a file - read it. If not then we drop through to do
+ // other initialisation.
diff --git a/recipes-qtopia/shopper/shopper_1.2.1.bb b/recipes-qtopia/shopper/shopper_1.2.1.bb
new file mode 100644
index 0000000..67a26d1
--- /dev/null
+++ b/recipes-qtopia/shopper/shopper_1.2.1.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Shopping list manager"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/zaurus-shopper/Shopper-${PV}.tar.gz \
+ file://gcc3.patch \
+ file://path_fix.patch"
+S = "${WORKDIR}/Shopper"
+
+inherit palmtop
+
+SHOPPER_DATADIR = "${palmtopdir}/share/shopper"
+CXXFLAGS_append += " -DSHOPPER_DATADIR='"${SHOPPER_DATADIR}"' "
+
+QMAKE_PROFILES = "Shopper.pro"
+
+pkg_postinst() {
+ /opt/QtPalmtop/bin/qcop QPE/System "linkChanged(QString)" 2>/dev/null
+ if [ -n "$D" ]; then false; fi
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/help/html \
+ ${D}${SHOPPER_DATADIR}
+ install -m 0755 ${S}/Shopper ${D}${palmtopdir}/bin/
+ install -m 0644 ${S}/Shopper.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${S}/Shopper.png ${D}${palmtopdir}/pics/
+ install -m 0644 ${S}/Shopper.html ${D}${palmtopdir}/help/html/
+ install -m 0644 ${S}/shoppinglist.xml ${D}${SHOPPER_DATADIR}/shoppinglist.xml
+}
+
+SRC_URI[md5sum] = "ed4d8ce2227abf7e68de687a8c930fa4"
+SRC_URI[sha256sum] = "0e1ab08b22742d18b9ee0288874f63ddd74591e1b9f29003fe66dd0ba2289bcf"