aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/zgscore
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/zgscore
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/zgscore')
-rw-r--r--recipes-qtopia/zgscore/files/qtopia17.patch25
-rw-r--r--recipes-qtopia/zgscore/zgscore_1.0.2.bb26
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes-qtopia/zgscore/files/qtopia17.patch b/recipes-qtopia/zgscore/files/qtopia17.patch
new file mode 100644
index 0000000..7741ca5
--- /dev/null
+++ b/recipes-qtopia/zgscore/files/qtopia17.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- zgscore-src/zgscore_main.cpp~qtopia17 2004-04-07 16:22:03.000000000 +0200
++++ zgscore-src/zgscore_main.cpp 2004-04-08 16:34:31.000000000 +0200
+@@ -1,5 +1,15 @@
+ #include "zgscore.h"
+ #include <qpe/qpeapplication.h>
+
+-QTOPIA_ADD_APPLICATION("zgs", ZGS)
+-QTOPIA_MAIN
++//QTOPIA_ADD_APPLICATION("zgs", ZGS)
++//QTOPIA_MAIN
++
++int main(int argc, char** argv)
++{
++ QPEApplication a( argc, argv );
++ ZGS* zgs = new ZGS();
++ a.showMainWidget( zgs );
++ a.exec();
++}
++
++
diff --git a/recipes-qtopia/zgscore/zgscore_1.0.2.bb b/recipes-qtopia/zgscore/zgscore_1.0.2.bb
new file mode 100644
index 0000000..ceb2d7a
--- /dev/null
+++ b/recipes-qtopia/zgscore/zgscore_1.0.2.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Zaurus Golf Score Application for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://nuke.cinlug.org/modules/Static_Docs/data/db/zgs/"
+PR = "r0"
+
+SRC_URI = "http://www.cinlug.org/modules/Static_Docs/data/db/zgs/zgscore_${PV}_arm.src.tar.gz \
+ file://qtopia17.patch"
+S = "${WORKDIR}/zgscore-src"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += 'TMAKE_LIBS-="-luuid" TMAKE_LIBS+="-lqpe" CONFIG+=qt CONFIG-=qtopia'
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics
+ install -m 0755 zgscore ${D}${palmtopdir}/bin/zgscore
+ install -m 0755 zgscore.png ${D}${palmtopdir}/pics/
+ install -m 0644 zgscore.desktop ${D}${palmtopdir}/apps/Applications/
+}
+
+SRC_URI[md5sum] = "98e9dd2db54015c0f5193c5427f02d50"
+SRC_URI[sha256sum] = "a2683b8a6a172017f0fe6392fb07d87a5c02fc2714fbff4c98dcae67db588636"