aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-libqrsync
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-opie/opie-libqrsync')
-rw-r--r--recipes-opie/opie-libqrsync/opie-libqrsync.inc14
-rw-r--r--recipes-opie/opie-libqrsync/opie-libqrsync_1.2.5.bb5
-rw-r--r--recipes-opie/opie-libqrsync/opie-libqrsync_cvs.bb5
3 files changed, 24 insertions, 0 deletions
diff --git a/recipes-opie/opie-libqrsync/opie-libqrsync.inc b/recipes-opie/opie-libqrsync/opie-libqrsync.inc
new file mode 100644
index 0000000..8e8b0bd
--- /dev/null
+++ b/recipes-opie/opie-libqrsync/opie-libqrsync.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "Qt wrapper for librsync"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+S = "${WORKDIR}/rsync"
+
+inherit opie
+
+do_install() {
+ oe_libinstall -a libqrsync ${D}${libdir}/
+ install -d ${D}${includedir}/
+ install -m 0644 qrsync.h ${D}${includedir}/
+}
diff --git a/recipes-opie/opie-libqrsync/opie-libqrsync_1.2.5.bb b/recipes-opie/opie-libqrsync/opie-libqrsync_1.2.5.bb
new file mode 100644
index 0000000..7121833
--- /dev/null
+++ b/recipes-opie/opie-libqrsync/opie-libqrsync_1.2.5.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_rsync.tar.bz2;name=split_rsync"
+SRC_URI[split_rsync.md5sum] = "ba4a4d5bcdd363987199de129b118a95"
+SRC_URI[split_rsync.sha256sum] = "c3b59ef92421b4592c04b388123f2f060c87ca093ae2b813b3c905323b088d6d"
diff --git a/recipes-opie/opie-libqrsync/opie-libqrsync_cvs.bb b/recipes-opie/opie-libqrsync/opie-libqrsync_cvs.bb
new file mode 100644
index 0000000..c5cd3c4
--- /dev/null
+++ b/recipes-opie/opie-libqrsync/opie-libqrsync_cvs.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=rsync"