aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/gnuplot/gnuplot-4.0.0
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/gnuplot/gnuplot-4.0.0')
-rw-r--r--recipes-qtopia/gnuplot/gnuplot-4.0.0/debian-separate-x11-package.patch59
-rw-r--r--recipes-qtopia/gnuplot/gnuplot-4.0.0/matrix.patch17
-rw-r--r--recipes-qtopia/gnuplot/gnuplot-4.0.0/subdirs.patch16
-rw-r--r--recipes-qtopia/gnuplot/gnuplot-4.0.0/term.patch20
4 files changed, 112 insertions, 0 deletions
diff --git a/recipes-qtopia/gnuplot/gnuplot-4.0.0/debian-separate-x11-package.patch b/recipes-qtopia/gnuplot/gnuplot-4.0.0/debian-separate-x11-package.patch
new file mode 100644
index 0000000..7afa0ee
--- /dev/null
+++ b/recipes-qtopia/gnuplot/gnuplot-4.0.0/debian-separate-x11-package.patch
@@ -0,0 +1,59 @@
+--- gnuplot-4.0.0.orig/src/term.c
++++ gnuplot-4.0.0/src/term.c
+@@ -1278,6 +1278,33 @@
+ return (t);
+ }
+
++#ifdef X11
++int
++x11driver_found()
++{
++ char *binname = "/gnuplot_x11";
++ char *fullname;
++ struct stat buf;
++
++ fullname = (char*)malloc(sizeof(X11_DRIVER_DIR) + sizeof(binname) + 1);
++ strcat(fullname, X11_DRIVER_DIR);
++ strcat(fullname, binname);
++
++ /* exists? */
++ if (stat(fullname, &buf)) {
++ free(fullname);
++ return 0;
++ }
++
++ free(fullname);
++ /* executable? */
++ if (buf.st_mode && S_IXOTH)
++ return 1;
++
++ return 0;
++}
++#endif
++
+ /*
+ * Routine to detect what terminal is being used (or do anything else
+ * that would be nice). One anticipated (or allowed for) side effect
+@@ -1356,12 +1383,18 @@
+ env_term = getenv("TERM"); /* try $TERM */
+ if (term_name == (char *) NULL
+ && env_term != (char *) NULL && strcmp(env_term, "xterm") == 0)
+- term_name = "x11";
++ term_name = "x11";
+ display = getenv("DISPLAY");
+ if (term_name == (char *) NULL && display != (char *) NULL)
+- term_name = "x11";
++ term_name = "x11";
+ if (X11_Display)
+- term_name = "x11";
++ term_name = "x11";
++ /* if x11 was selected check for driver */
++ if (term_name && (strcmp(term_name, "x11") == 0) && !x11driver_found() && isatty(fileno(stdin))) {
++ printf("*** X11 output driver not found, switching to dumb terminal!\n");
++ printf("*** If you want to use the X11 output, please install the ""gnuplot-x11"" package\n");
++ term_name = "dumb";
++ };
+ #endif /* x11 */
+
+ #ifdef AMIGA
+
diff --git a/recipes-qtopia/gnuplot/gnuplot-4.0.0/matrix.patch b/recipes-qtopia/gnuplot/gnuplot-4.0.0/matrix.patch
new file mode 100644
index 0000000..10f56d9
--- /dev/null
+++ b/recipes-qtopia/gnuplot/gnuplot-4.0.0/matrix.patch
@@ -0,0 +1,17 @@
+--- gnuplot-4.0.0/src/matrix.c.old 2004-04-13 18:23:58.000000000 +0100
++++ gnuplot-4.0.0/src/matrix.c 2005-03-01 12:38:07.068232748 +0000
+@@ -290,9 +290,12 @@
+ *d = 1.0;
+ for (ar = a, lim = &(a[n]); ar < lim; ar++) {
+ large = 0.0;
+- for (ac = *ar, limc = &(ac[n]); ac < limc;)
+- if ((temp = fabs(*ac++)) > large)
++ for (ac = *ar, limc = &(ac[n]); ac < limc;){
++ temp = *ac++;
++ temp = fabs(temp);
++ if (temp > large)
+ large = temp;
++ }
+ if (large == 0.0)
+ int_error(NO_CARET, "Singular matrix in LU-DECOMP");
+ *dp++ = 1 / large;
diff --git a/recipes-qtopia/gnuplot/gnuplot-4.0.0/subdirs.patch b/recipes-qtopia/gnuplot/gnuplot-4.0.0/subdirs.patch
new file mode 100644
index 0000000..69c7753
--- /dev/null
+++ b/recipes-qtopia/gnuplot/gnuplot-4.0.0/subdirs.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- gnuplot-4.0.0/Makefile.am~nodocs
++++ gnuplot-4.0.0/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to produce Makefile.in -*-Makefile-*-
+ AUTOMAKE_OPTIONS = foreign 1.2h
+
+-SUBDIRS = config m4 term src docs lisp man demo tutorial
++SUBDIRS = config m4 term src man tutorial
+
+ EXTRA_DIST = BUGS CodeStyle Copyright FAQ GNUmakefile INSTALL INSTALL.gnu \
+ Makefile.maint PATCHLEVEL PGPKEYS PORTING README README.1ST README.exp \
diff --git a/recipes-qtopia/gnuplot/gnuplot-4.0.0/term.patch b/recipes-qtopia/gnuplot/gnuplot-4.0.0/term.patch
new file mode 100644
index 0000000..2979b5e
--- /dev/null
+++ b/recipes-qtopia/gnuplot/gnuplot-4.0.0/term.patch
@@ -0,0 +1,20 @@
+--- gnuplot-4.0.0/src/term.h.old 2005-03-01 15:17:46.424111687 +0000
++++ gnuplot-4.0.0/src/term.h 2005-03-01 15:18:50.961405665 +0000
+@@ -54,6 +54,7 @@
+ */
+ #ifdef SHORT_TERMLIST
+ # include "dumb.trm" /* dumb terminal */
++# include "qtopia.trm" /* QTopia terminal */
+ # include "post.trm" /* postscript */
+ # include "table.trm" /* built-in, but used for the documentation */
+ # if !(defined(OS2) || defined(MSDOS) || defined(_Windows) || defined(ATARI) || defined(MTOS) || defined(AMIGA))
+@@ -432,6 +433,9 @@
+ /* TeXDraw drawing package for LaTeX */
+ #include "texdraw.trm"
+
++/* Qtopia */
++#include "qtopia.trm"
++
+ /* METAFONT */
+ #include "metafont.trm"
+