aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/roadmap/files/options.mk.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/roadmap/files/options.mk.patch')
-rw-r--r--recipes-qtopia/roadmap/files/options.mk.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-qtopia/roadmap/files/options.mk.patch b/recipes-qtopia/roadmap/files/options.mk.patch
new file mode 100644
index 0000000..196f16e
--- /dev/null
+++ b/recipes-qtopia/roadmap/files/options.mk.patch
@@ -0,0 +1,34 @@
+--- roadmap-1.1.0/src/options.mk.old 2008-01-09 22:08:00.000000000 -0600
++++ roadmap-1.1.0/src/options.mk 2008-01-09 23:06:29.000000000 -0600
+@@ -177,10 +177,7 @@ ifeq ($(strip $(AGG)),NO)
+ else
+ LIBS += -laggfontfreetype -lagg -lfreetype
+ CFLAGS += -DAGG_PIXFMT=pixfmt_$(AGG) \
+- -I$(TOP)/agg_support \
+- -I/usr/include/agg2 \
+- -I/usr/local/include/agg2 \
+- -I/usr/include/freetype2
++ -I$(TOP)/agg_support
+ CANVAS_OBJS = roadmap_canvas_agg.o \
+ $(TOP)/agg_support/roadmap_canvas.o
+ endif
+@@ -188,7 +185,7 @@ endif
+ # bidirectional text lib
+ ifneq ($(strip $(BIDI)),NO)
+ LIBS += -lfribidi
+- CFLAGS += -DUSE_FRIBIDI -I/usr/include/fribidi
++ CFLAGS += -DUSE_FRIBIDI
+ endif
+
+ # RoadMap internal profiling
+@@ -205,8 +202,8 @@ else
+ endif
+
+
+-CFLAGS += -I$(TOP) -I/usr/local/include -DNDEBUG
++CFLAGS += -I$(TOP) -DNDEBUG
+
+-LIBS := -L/usr/local/lib $(LIBS) -lm
++LIBS := $(LIBS) -lm
+
+ CXXFLAGS = $(CFLAGS)