aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-bitarray_1.2.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-01-13 09:09:40 -0800
committerTim Orling <ticotimo@gmail.com>2020-01-23 23:37:58 -0800
commit3abad20fe34d39bd6e2447e12964b175b11f3b79 (patch)
tree871c8656aa8807ca584cadb21be74f59cc060ddf /recipes-devtools/python/python-bitarray_1.2.1.bb
parent3c212e05bb6680559bd67e3c235a57154e6a21f8 (diff)
downloadmeta-python2-3abad20fe34d39bd6e2447e12964b175b11f3b79.tar.gz
python-bitarray: 1.2.0 -> 1.2.1
License-Update: updated to 2019. (From meta-openembedded commit: d612ea4094945bde499c46df09ff33e38950a2dc) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-bitarray_1.2.1.bb')
-rw-r--r--recipes-devtools/python/python-bitarray_1.2.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-bitarray_1.2.1.bb b/recipes-devtools/python/python-bitarray_1.2.1.bb
new file mode 100644
index 0000000..25b9d84
--- /dev/null
+++ b/recipes-devtools/python/python-bitarray_1.2.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A high-level Python efficient arrays of booleans -- C extension"
+DESCRIPTION = "This module provides an object type which efficiently represents \
+an array of booleans. Bitarrays are sequence types and behave very much like \
+usual lists. Eight bits are represented by one byte in a contiguous block of \
+memory. The user can select between two representations: little-endian and \
+big-endian. All of the functionality is implemented in C. Methods for \
+accessing the machine representation are provided. This can be useful when bit \
+level access to binary files is required, such as portable bitmap image files \
+(.pbm). Also, when dealing with compressed data which uses variable bit length \
+encoding, you may find this module useful."
+HOMEPAGE = "https://github.com/ilanschnell/bitarray"
+SECTION = "devel/python"
+
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=dc301a25ebe210dcc53b0a2d5a038eae"
+
+SRC_URI[md5sum] = "a46bf869f6adf34f5b0dc82b469793b7"
+SRC_URI[sha256sum] = "2ed675f460bb0d3d66fd8042a6f1f0d36cf213e52e72a745283ddb245da7b9cf"
+
+inherit pypi setuptools
+
+BBCLASSEXTEND = "native nativesdk"