aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-11-05 17:09:27 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2021-11-05 17:16:00 +0100
commitbb9e1ac40b02bc7d1cab5f2432adc1b3aaf09b9a (patch)
treeb801e6931b7e68642b2267830b8e7bc210324a7f /recipes-devtools
parent75350866970ae4b0bdba1082689ff0f2a8135127 (diff)
downloadmeta-python2-bb9e1ac40b02bc7d1cab5f2432adc1b3aaf09b9a.tar.gz
recipes: explicitly set branch name and use https protocol for github.com
* github decided that nobody should use git:// https://github.blog/2021-09-01-improving-git-protocol-security-github/#no-more-unauthenticated-git and starting today all the builds were failing to fetch the metadata layers from github like: 2021-11-01T18:53:26 INFO _main_ Updating [meta-ros] fatal: remote error: The unauthenticated git protocol on port 9418 is no longer supported. Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information. this was just a "test" as they said: "November 2, 2021: We'll also run several short brownouts on this date." and it will be completely disabled on January 11 2022. * fixes warnings like: WARNING: meta-python2/recipes-extended/python-pyparted/python-pyparted_git.bb: URL: git://github.com/rhinstaller/pyparted.git;protocol=https does not set any branch parameter. The future default branch used by tools and repositories is uncertain and we will therefore soon require this is set in all git urls. WARNING: meta-python2/recipes-devtools/gyp/gyp-py2_git.bb: URL: git://chromium.googlesource.com/external/gyp;protocol=https does not set any branch parameter. The future default branch used by tools and repositories is uncertain and we will therefore soon require this is set in all git urls. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/gyp/gyp-py2_git.bb2
-rw-r--r--recipes-devtools/python/python-cpuset_1.6.bb2
-rw-r--r--recipes-devtools/python/python-feedformatter_0.4.bb2
-rw-r--r--recipes-devtools/python/python-scandir_1.10.0.bb2
-rw-r--r--recipes-devtools/python/python-which_1.1.0.bb2
5 files changed, 5 insertions, 5 deletions
diff --git a/recipes-devtools/gyp/gyp-py2_git.bb b/recipes-devtools/gyp/gyp-py2_git.bb
index 714d5d1..0a7cf06 100644
--- a/recipes-devtools/gyp/gyp-py2_git.bb
+++ b/recipes-devtools/gyp/gyp-py2_git.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
SECTION = "devel"
-SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
+SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https;branch=master"
SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
S = "${WORKDIR}/git"
diff --git a/recipes-devtools/python/python-cpuset_1.6.bb b/recipes-devtools/python/python-cpuset_1.6.bb
index eb9adaf..0d783b7 100644
--- a/recipes-devtools/python/python-cpuset_1.6.bb
+++ b/recipes-devtools/python/python-cpuset_1.6.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
S = "${WORKDIR}/git"
SRCREV = "6c46d71a1c6ee711063153b9f7787280128f7252"
-SRC_URI = "git://github.com/lpechacek/cpuset.git;protocol=https;"
+SRC_URI = "git://github.com/lpechacek/cpuset.git;protocol=https;;branch=master"
inherit distutils
diff --git a/recipes-devtools/python/python-feedformatter_0.4.bb b/recipes-devtools/python/python-feedformatter_0.4.bb
index 20fabad..efb0ea8 100644
--- a/recipes-devtools/python/python-feedformatter_0.4.bb
+++ b/recipes-devtools/python/python-feedformatter_0.4.bb
@@ -11,7 +11,7 @@ SECTION = "devel/python"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=258e3f39e2383fbd011035d04311008d"
-SRC_URI = "git://github.com/marianoguerra/feedformatter.git"
+SRC_URI = "git://github.com/marianoguerra/feedformatter.git;branch=master;protocol=https"
SRCREV = "7391193c83e10420b5a2d8ef846d23fc368c6d85"
S = "${WORKDIR}/git"
diff --git a/recipes-devtools/python/python-scandir_1.10.0.bb b/recipes-devtools/python/python-scandir_1.10.0.bb
index df1a499..ecff247 100644
--- a/recipes-devtools/python/python-scandir_1.10.0.bb
+++ b/recipes-devtools/python/python-scandir_1.10.0.bb
@@ -4,7 +4,7 @@ AUTHOR = "Ben Hoyt"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=482ee62da51806409d432a80eed4e3ea"
-SRC_URI = "git://github.com/benhoyt/scandir.git"
+SRC_URI = "git://github.com/benhoyt/scandir.git;branch=master;protocol=https"
SRCREV = "982e6ba60e7165ef965567eacd7138149c9ce292"
S = "${WORKDIR}/git"
diff --git a/recipes-devtools/python/python-which_1.1.0.bb b/recipes-devtools/python/python-which_1.1.0.bb
index df30fa1..3077011 100644
--- a/recipes-devtools/python/python-which_1.1.0.bb
+++ b/recipes-devtools/python/python-which_1.1.0.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=030b09798681482b9ad12ac47be496ea"
inherit setuptools pypi python-dir
SRCREV = "425bdeeb2d87c36e2313dc4b8d69ff2bb5a02ee9"
-PYPI_SRC_URI = "git://github.com/trentm/which"
+PYPI_SRC_URI = "git://github.com/trentm/which;branch=master;protocol=https"
S = "${WORKDIR}/git"