aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-02-16 14:52:52 +0800
committerChen Qi <Qi.Chen@windriver.com>2016-02-16 15:04:03 +0800
commit9b7f64a99c4d7183273e27a0f4634f27a8c2149a (patch)
tree3ce0020f13d12a16bd246d81eeac26a710219f2f
parentbd06944249c3de3f629c013e14f446464441c4da (diff)
downloadopenembedded-core-contrib-ChenQi/coreutils-6.9-acl.tar.gz
coreutils: fix problem with acl for 6.9 versionChenQi/coreutils-6.9-acl
If 'acl' is not in DISTRO_FEATURES, building coreutils 6.9 would sometimes fail. The problem could be reproduced by executing the following command. `bitbake acl && bitbake coreutils -c configure && bitbake acl -c cleansstate && bitbake coreutils -c compile' Fix this problem by setting the correct value for the 'acl' PACKAGECONFIG. [YOCTO #8906] Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-core/coreutils/coreutils-6.9/coreutils-build-with-acl.patch28
-rw-r--r--meta/recipes-core/coreutils/coreutils_6.9.bb3
2 files changed, 1 insertions, 30 deletions
diff --git a/meta/recipes-core/coreutils/coreutils-6.9/coreutils-build-with-acl.patch b/meta/recipes-core/coreutils/coreutils-6.9/coreutils-build-with-acl.patch
deleted file mode 100644
index 8273d78eb3..0000000000
--- a/meta/recipes-core/coreutils/coreutils-6.9/coreutils-build-with-acl.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
-Fix the following issue so that coreutils can build with ACL:
-
-configure: WARNING: libacl development library was not found or not usable.
-configure: WARNING: GNU coreutils will be built without ACL support.
-
-Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
----
- m4/acl.m4 | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/m4/acl.m4 b/m4/acl.m4
-index d6a448a..a9d4836 100644
---- a/m4/acl.m4
-+++ b/m4/acl.m4
-@@ -159,7 +159,7 @@ AC_DEFUN([gl_ACL_GET_FILE],
- ]])],
- [gl_cv_func_working_acl_get_file=yes],
- [gl_cv_func_working_acl_get_file=no],
-- [gl_cv_func_working_acl_get_file=cross-compiling])])
-+ [gl_cv_func_working_acl_get_file=yes])])
-
- AS_IF([test $gl_cv_func_working_acl_get_file = yes], [$1], [$2])
- ])
---
-1.7.7
-
diff --git a/meta/recipes-core/coreutils/coreutils_6.9.bb b/meta/recipes-core/coreutils/coreutils_6.9.bb
index e9f82abc8b..9ce717d1aa 100644
--- a/meta/recipes-core/coreutils/coreutils_6.9.bb
+++ b/meta/recipes-core/coreutils/coreutils_6.9.bb
@@ -23,7 +23,6 @@ SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.bz2 \
file://coreutils-fix-install.patch \
file://man-touch.patch \
file://coreutils_fix_for_automake-1.12.patch \
- file://coreutils-build-with-acl.patch \
file://coreutils-fix-texinfo.patch \
file://fix_for_manpage_building.patch \
file://loadavg.patch \
@@ -41,7 +40,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}
# with, without, depends, rdepends
#
-PACKAGECONFIG[acl] = "ac_cv_header_sys_acl_h=yes,ac_cv_header_sys_acl_h=no,acl,"
+PACKAGECONFIG[acl] = "ac_cv_header_sys_acl_h=yes ac_cv_header_acl_libacl_h=yes ac_cv_search_acl_get_file=-lacl,ac_cv_header_sys_acl_h=no ac_cv_header_acl_libacl_h=no ac_cv_search_acl_get_file=,acl,"
# [ gets a special treatment and is not included in this