aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-01-13 11:14:02 +0800
committerChen Qi <Qi.Chen@windriver.com>2016-01-13 11:20:09 +0800
commit35fd9829f35bd0486288037c7f0a3cf5ada85948 (patch)
tree84825fc667851e4160074a56e0f36adc5e956020
parent541315d6c56df6448f64c262f99d43d5c1e9400b (diff)
downloadopenembedded-core-contrib-ChenQi/cups-2.1.2.tar.gz
cups: upgrade to 2.1.2ChenQi/cups-2.1.2
Add PACKAGECONFIG for systemd. And install our own systemd unit files. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-extended/cups/cups.inc18
-rw-r--r--meta/recipes-extended/cups/cups_2.0.4.bb6
-rw-r--r--meta/recipes-extended/cups/cups_2.1.2.bb6
3 files changed, 18 insertions, 12 deletions
diff --git a/meta/recipes-extended/cups/cups.inc b/meta/recipes-extended/cups/cups.inc
index 5aa365d095..c013205908 100644
--- a/meta/recipes-extended/cups/cups.inc
+++ b/meta/recipes-extended/cups/cups.inc
@@ -27,7 +27,9 @@ GROUPADD_PARAM_${PN} = "--system lpadmin"
SYSTEMD_SERVICE_${PN} = "cups.socket cups.path cups.service"
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
+PACKAGECONFIG[systemd] = "--enable-systemd --with-systemd=${systemd_unitdir}/system/,--disable-systemd,systemd"
PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
PACKAGECONFIG[pam] = "--enable-pam, --disable-pam, libpam"
@@ -80,11 +82,15 @@ do_install () {
fi
# Install systemd unit files
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/cups.socket ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/cups.path ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/cups.service ${D}${systemd_unitdir}/system
- sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/cups.service
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ # Use our own unit files
+ [ -d ${D}${systemd_unitdir}/system ] && rm -rf ${D}${systemd_unitdir}/system
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/cups.socket ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/cups.path ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/cups.service ${D}${systemd_unitdir}/system
+ sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/cups.service
+ fi
}
python do_package_append() {
diff --git a/meta/recipes-extended/cups/cups_2.0.4.bb b/meta/recipes-extended/cups/cups_2.0.4.bb
deleted file mode 100644
index bad73b34f0..0000000000
--- a/meta/recipes-extended/cups/cups_2.0.4.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require cups.inc
-
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6c5a350596fba02754bd96eb6df3afd0"
-
-SRC_URI[md5sum] = "f5c847d9a4fac6c4c66fb0526a7afaae"
-SRC_URI[sha256sum] = "e1d5e68d9f24faca317aeaebc164c34102813bc0f1d69c00b3a59b49c49f4abd"
diff --git a/meta/recipes-extended/cups/cups_2.1.2.bb b/meta/recipes-extended/cups/cups_2.1.2.bb
new file mode 100644
index 0000000000..0c1e75d9e2
--- /dev/null
+++ b/meta/recipes-extended/cups/cups_2.1.2.bb
@@ -0,0 +1,6 @@
+require cups.inc
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6c5a350596fba02754bd96eb6df3afd0"
+
+SRC_URI[md5sum] = "b3ba0ca676d56857bbd9b182ef4b14b3"
+SRC_URI[sha256sum] = "bab0ca3ba80eae48319b3a6b19a5b14fad5ce230f30151a0cfa4c0271df281ad"