aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-07-27 10:21:44 +0800
committerChen Qi <Qi.Chen@windriver.com>2016-07-27 13:31:18 +0800
commit80d72a61a1aa719b221f0ce3005effd1e9d237e1 (patch)
treef07115a2171fdb34edd0a94e60a0c7acd111714b
parent0afb5f75385876d2ecbca040449289bb39fae4d7 (diff)
downloadopenembedded-core-contrib-ChenQi/python-fixes.tar.gz
python3-setuptools: extend to nativesdkChenQi/python-fixes
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_22.0.5.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_22.0.5.bb b/meta/recipes-devtools/python/python3-setuptools_22.0.5.bb
index fb2931c3f2..90c242dd81 100644
--- a/meta/recipes-devtools/python/python3-setuptools_22.0.5.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_22.0.5.bb
@@ -2,6 +2,7 @@ require python-setuptools.inc
DEPENDS += "python3"
DEPENDS_class-native += "python3-native"
+DEPENDS_class-nativesdk += "python3-nativesdk"
inherit distutils3
@@ -14,11 +15,11 @@ do_install_append() {
echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
}
-RDEPENDS_${PN} = "\
+RDEPENDS_${PN}_class-native = "\
python3-distutils \
python3-compression \
"
-RDEPENDS_${PN}_class-target = "\
+RDEPENDS_${PN} = "\
python3-ctypes \
python3-distutils \
python3-email \
@@ -34,4 +35,4 @@ RDEPENDS_${PN}_class-target = "\
python3-unittest \
python3-xml \
"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"