aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-09-01 04:44:26 -0400
committerChen Qi <Qi.Chen@windriver.com>2014-09-03 15:05:44 +0800
commit9e8bbb3030956b1dac65ab4e84de3ad3aef74d56 (patch)
tree6ab37ecc32598c266224a0a789d6364720d33250
parent05de0efab67427f85862c4ced311e82ab2ce90b1 (diff)
downloadopenembedded-core-contrib-ChenQi/systemd-misc-fixes.tar.gz
systemd: enable forwarding messages to syslog daemonChenQi/systemd-misc-fixes
In systemd_216, journald by default doesn't forward messages to syslog daemon. This breaks the oeqa testing cases. So we enable forwarding the messages for now. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-core/systemd/systemd_216.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_216.bb b/meta/recipes-core/systemd/systemd_216.bb
index 929b8aef25..a7fd71edd0 100644
--- a/meta/recipes-core/systemd/systemd_216.bb
+++ b/meta/recipes-core/systemd/systemd_216.bb
@@ -143,6 +143,9 @@ do_install() {
ln -sf ../systemd-update-utmp-runlevel.service ${D}${systemd_unitdir}/system/poweroff.target.wants/systemd-update-utmp-runlevel.service
ln -sf ../systemd-update-utmp-runlevel.service ${D}${systemd_unitdir}/system/reboot.target.wants/systemd-update-utmp-runlevel.service
ln -sf ../systemd-update-utmp-runlevel.service ${D}${systemd_unitdir}/system/rescue.target.wants/systemd-update-utmp-runlevel.service
+
+ # Enable journal to forward message to syslog daemon
+ sed -i -e 's/.*ForwardToSyslog.*/ForwardToSyslog=yes/' ${D}${sysconfdir}/systemd/journald.conf
}
do_install_ptest () {