aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-02-10 17:10:38 +0800
committerChen Qi <Qi.Chen@windriver.com>2015-02-10 17:12:17 +0800
commit9a96f78fbc6562ff7813121cab49a6ee8e1bd34a (patch)
tree5bafcfbd51326586038b88b830e592d8b5e32af0
parent234b4feef24ffe0cea9b6d88d9c51a05ee63db9e (diff)
downloadopenembedded-core-contrib-ChenQi/systemd-multilib.tar.gz
systemd: fix do_install failure in case of multilibChenQi/systemd-multilib
Instead of using ${libdir}, we should use ${prefix}${nonarch_base_libdir}, so that we don't get error like below at do_install time. | sed: can't read /home/chenqi/poky/build-systemd/tmp/work/core2-64-poky-linux/systemd/1_216+gitAUTOINC+5d0ae62c66-r0/image/usr/lib64/tmpfiles.d/systemd.conf: No such file or directory | WARNING: exit code 2 from a shell command. | ERROR: Function failed: do_install (log file is located at /home/chenqi/poky/build-systemd/tmp/work/core2-64-poky-linux/systemd/1_216+gitAUTOINC+5d0ae62c66-r0/temp/log.do_install.327) Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-core/systemd/systemd_216.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_216.bb b/meta/recipes-core/systemd/systemd_216.bb
index 569e88c240..f675c6ac5a 100644
--- a/meta/recipes-core/systemd/systemd_216.bb
+++ b/meta/recipes-core/systemd/systemd_216.bb
@@ -158,7 +158,7 @@ do_install() {
sed -i -e 's/ remote-fs.target$//' ${D}${systemd_unitdir}/system/systemd-journal-flush.service
# this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it
# for existence else it fails
- ${@bb.utils.contains('PACKAGECONFIG', 'networkd', '', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${libdir}/tmpfiles.d/systemd.conf', d)}
+ ${@bb.utils.contains('PACKAGECONFIG', 'networkd', '', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${prefix}${nonarch_base_libdir}/tmpfiles.d/systemd.conf', d)}
}
do_install_ptest () {