aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-12-30 17:11:57 +0800
committerChen Qi <Qi.Chen@windriver.com>2015-01-04 10:08:17 +0800
commit24dbafa66cc993d1b626ae27ea3e462c0af54718 (patch)
tree06048048d7edf5e6c0e0d68c5cda5bc037d18fdd
parent96dbf97132466f445139272c0e41c5a9319e5b70 (diff)
downloadopenembedded-core-contrib-ChenQi/util-linux-2.25.2.tar.gz
libsm: remove dependency on e2fsprogsChenQi/util-linux-2.25.2
This patch is to solve the following circular dependency problem. systemd -> dbus -> libsm -> e2fsprogs -> util-linux -> systemd libsm doesn't have any dependency on e2fsprogs. It might be some dependency on util-linux's libuuid, controlled by configure options. So e2fsprogs should be removed from the DEPENDS variable. Ideally, we should add a PACKAGECONFIG for 'libuuid' for libsm. However, if libsm depends on util-linux, we would have the circular dependency described above. That's why this patch explicitly set '--without-libuuid' in EXTRA_OECONF. libsm would still be working well because it would fall back to an internal algorithm to do the uuid stuff. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb b/meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb
index 180acfae0b..1925136369 100644
--- a/meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb
+++ b/meta/recipes-graphics/xorg-lib/libsm_1.2.2.bb
@@ -11,7 +11,12 @@ require xorg-lib-common.inc
LICENSE = "MIT-style"
LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb37f44e02bdbde80546024400728d"
-DEPENDS += "libice xproto xtrans e2fsprogs"
+DEPENDS += "libice xproto xtrans"
+
+# libSM can work without libuuid, we explicitly disable it to break the following circular dependency
+# when DISTRO_FEATURES contains 'systemd' and 'x11'.
+# systemd -> dbus -> libsm -> util-linux -> systemd
+EXTRA_OECONF += "--without-libuuid"
PE = "1"