aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2016-07-07 08:41:54 -0600
committerDaniel McGregor <daniel.mcgregor@vecima.com>2016-07-08 12:34:49 -0600
commit0e4c8780882d621e9b80d920a9ed9a7ab3814383 (patch)
treec768a8f70be5861ee04c79c3a5439837e1e05b20
parent10756e9db44816622239ab48a0fdf91642f688a9 (diff)
downloadopenembedded-core-contrib-dankm/cft-patchelf.tar.gz
db: fix uninative builddankm/cft-patchelf
Add write permissions in the native cases. patchelf 0.9 no longer overwrites read-only files. Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
-rw-r--r--meta/recipes-support/db/db_6.0.30.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-support/db/db_6.0.30.bb b/meta/recipes-support/db/db_6.0.30.bb
index 018dd58f67..95c1a4398b 100644
--- a/meta/recipes-support/db/db_6.0.30.bb
+++ b/meta/recipes-support/db/db_6.0.30.bb
@@ -117,6 +117,14 @@ do_install_append() {
chown -R root:root ${D}
}
+do_install_append_class-native() {
+ chmod -R u+w ${D}
+}
+
+do_install_append_class-nativesdk() {
+ chmod -R u+w ${D}
+}
+
INSANE_SKIP_${PN} = "dev-so"
INSANE_SKIP_${PN}-cxx = "dev-so"