aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-01-22 16:36:17 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-02 19:49:38 +0200
commitfe20c5d5bc76c14dc244f028471b4d56165d3297 (patch)
tree21bf80300a0668962a9b1ac8a0f43f406a2cd5d0
parentf6acfb8139a3ac53dc9103cbe074d7ab5281795f (diff)
downloadopenembedded-core-contrib-jansa/world-image.tar.gz
oe-core: add world-imagejansa/world-image
* this depends on newer bitbake * similar to world target, but collects all PACKAGES * recipes marked with EXCLUDE_FROM_WORLD are excluded from world as well as world-image * recipes marked with EXCLUDE_FROM_WORLD_IMAGE are excluded completely from world-image, sometimes you can build 2 recipes in same sysroot, but cannot install them in the same image * PACKAGES listed in EXCLUDE_PACKAGES_FROM_WORLD_IMAGE are also excluded. You can remove e.g. ${PN}-dbg, but keep all other PACKAGES. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta/recipes-core/images/world-image.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-core/images/world-image.bb b/meta/recipes-core/images/world-image.bb
new file mode 100644
index 0000000000..ab195c39d3
--- /dev/null
+++ b/meta/recipes-core/images/world-image.bb
@@ -0,0 +1,10 @@
+# IMAGE_INSTALL is set from bitbake itself to union of all PACKAGES
+# from all recipes which are not marked as:
+# EXCLUDE_FROM_WORLD or EXCLUDE_FROM_WORLD_IMAGE
+# or individual packages listed in
+# EXCLUDE_PACKAGES_FROM_WORLD_IMAGE
+
+inherit image
+
+# don't build this in regular world builds
+EXCLUDE_FROM_WORLD = "1"