summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-06-24 15:29:52 -0700
committerKhem Raj <raj.khem@gmail.com>2020-06-24 15:29:52 -0700
commitbe991bef8b39a7e1221a7df9027f0fdfbbd08473 (patch)
tree77ca16dd9501884f6d1df3d08119335fc9970425
parent9217ed1446b5c409f68274517b5e0ae5acab4ec5 (diff)
downloadopenembedded-core-contrib-kraj/busybox-ar.tar.gz
opkg-utils: Do not use -D option to binutils archiverkraj/busybox-ar
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/no_deterministic_archives.patch23
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb1
2 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/no_deterministic_archives.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/no_deterministic_archives.patch
new file mode 100644
index 0000000000..30483155e5
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils/no_deterministic_archives.patch
@@ -0,0 +1,23 @@
+busybox ar is not able to handle deterministic archives produced with binutils archiver
+since it alters the archive headers by shunting certain fields, busybox ar operates on fixed
+bytes which gets then confused in parsing the file header.
+
+This is a workaround until busybox is fixed for
+
+https://bugs.busybox.net/show_bug.cgi?id=13036
+
+Upstream-Status: Inappropriate
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/opkg-build
++++ b/opkg-build
+@@ -324,7 +324,7 @@ fi
+
+ rm -f $pkg_file
+ if [ "$outer" = "ar" ] ; then
+- ( cd $tmp_dir && ar -crfD $pkg_file ./debian-binary ./control.tar.gz ./data.tar.$cext )
++ ( cd $tmp_dir && ar -crfU $pkg_file ./debian-binary ./control.tar.gz ./data.tar.$cext )
+ else
+ ( cd $tmp_dir && tar -c $tsortargs --mtime=@$build_date $tarformat ./debian-binary ./control.tar.gz ./data.tar.$cext | gzip $zipargs > $pkg_file )
+ fi
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb
index 9315240190..201206664a 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb
@@ -9,6 +9,7 @@ PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtu
SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
file://fix-reproducibility.patch \
+ file://no_deterministic_archives.patch \
"
UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"