aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2015-04-10 13:34:29 +0200
committerAndreas Oberritter <obi@opendreambox.org>2015-06-22 12:49:06 +0200
commite2c05a0595db0e1913b2c26be79846b43d7a9e3b (patch)
treeedbf10ba4b8da633ca5a7f8910467417d3b7e1e9
parent4378a28c3a26b8b537c37d14c1489d5a2c6afaae (diff)
downloadopenembedded-core-contrib-obi/denzil.tar.gz
binutils: backport patch to fix build with gcc-4.9obi/denzil
* backported from 2.23.2, fixes: work/x86_64-linux/binutils-native/2.23.1-r3/binutils-2.23.1/gas/write.c:409:24: error: 'dummy.fr_type' may be used uninitialized in this function [-Werror=maybe-uninitialized] gas_assert (prev_frag->fr_type != 0); ^ work/x86_64-linux/binutils-native/2.23.1-r3/binutils-2.23.1/gas/write.c:392:9: note: 'dummy' was declared here fragS dummy, *prev_frag = &dummy; ^ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 8c5396bd3b7f1eef3d53ebf0404189fd75f1d5e1) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-devtools/binutils/binutils/0001-write.c-chain_frchains_together_1-Reorder-assertion-.patch30
-rw-r--r--meta/recipes-devtools/binutils/binutils_2.22.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/binutils/binutils/0001-write.c-chain_frchains_together_1-Reorder-assertion-.patch b/meta/recipes-devtools/binutils/binutils/0001-write.c-chain_frchains_together_1-Reorder-assertion-.patch
new file mode 100644
index 0000000000..ffe6852dff
--- /dev/null
+++ b/meta/recipes-devtools/binutils/binutils/0001-write.c-chain_frchains_together_1-Reorder-assertion-.patch
@@ -0,0 +1,30 @@
+From c50d883cb61ff9917464cb695a0fd83fdb0f9c20 Mon Sep 17 00:00:00 2001
+From: Alan Modra <amodra@bigpond.net.au>
+Date: Mon, 21 Jan 2013 13:48:31 +0000
+Subject: [PATCH] write.c (chain_frchains_together_1): Reorder assertion to
+ avoid uninit warning.
+
+Upstream-Status: Backport from 2.23.2
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ gas/write.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/gas/write.c b/gas/write.c
+index a467147..56ebb6c 100644
+--- a/gas/write.c
++++ b/gas/write.c
+@@ -406,8 +406,8 @@ chain_frchains_together_1 (segT section, struct frchain *frchp)
+ prev_fix = frchp->fix_tail;
+ }
+ }
+- gas_assert (prev_frag->fr_type != 0);
+- gas_assert (prev_frag != &dummy);
++ gas_assert (prev_frag != &dummy
++ && prev_frag->fr_type != 0);
+ prev_frag->fr_next = 0;
+ return prev_frag;
+ }
+--
+2.3.5
+
diff --git a/meta/recipes-devtools/binutils/binutils_2.22.bb b/meta/recipes-devtools/binutils/binutils_2.22.bb
index 59f14f51c4..84d008cf70 100644
--- a/meta/recipes-devtools/binutils/binutils_2.22.bb
+++ b/meta/recipes-devtools/binutils/binutils_2.22.bb
@@ -33,6 +33,7 @@ SRC_URI = "\
file://binutils-armv5e.patch \
file://replace_macros_with_static_inline.patch \
file://0001-Fix-MMIX-build-breakage-from-bfd_set_section_vma-cha.patch \
+ file://0001-write.c-chain_frchains_together_1-Reorder-assertion-.patch \
"
SRC_URI[md5sum] = "ee0f10756c84979622b992a4a61ea3f5"