aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-08-18 22:06:17 -0700
committerRobert Yang <liezhi.yang@windriver.com>2015-08-19 00:49:04 -0700
commit7f16380e7f6a96b203f3b54738330785685ed093 (patch)
tree062b6b01bf65415627efc19dace8a2f5d19f38fd
parent059db140885bad379534e6ec713f3ceb4e18faea (diff)
downloadopenembedded-core-contrib-rbt/glibc.tar.gz
glibc: use cross-rpcgen to replace host's rpcgenrbt/glibc
There might be unexpected errors when use host's rpcgen. [YOCTO #8181] Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-core/glibc/glibc_2.22.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.22.bb b/meta/recipes-core/glibc/glibc_2.22.bb
index 6aaf72260a..f0e1fad450 100644
--- a/meta/recipes-core/glibc/glibc_2.22.bb
+++ b/meta/recipes-core/glibc/glibc_2.22.bb
@@ -97,10 +97,6 @@ do_configure () {
# calls for now
# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
# version check and doesn't really help with anything
- if [ -z "`which rpcgen`" ]; then
- echo "rpcgen not found. Install glibc-devel."
- exit 1
- fi
(cd ${S} && gnu-configize) || die "failure in running gnu-configize"
find ${S} -name "configure" | xargs touch
CPPFLAGS="" oe_runconf
@@ -119,7 +115,7 @@ do_compile () {
for r in ${rpcsvc}; do
h=`echo $r|sed -e's,\.x$,.h,'`
rm -f $h
- rpcgen -h $r -o $h || bbwarn "${PN}: unable to generate header for $r"
+ ${B}/sunrpc/cross-rpcgen -h $r -o $h || bbwarn "${PN}: unable to generate header for $r"
done
)
echo "Adjust ldd script"