aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-03-29 22:58:35 -0700
committerRobert Yang <liezhi.yang@windriver.com>2016-03-30 00:24:18 -0700
commit3ea4adf79751bb2c9a140cec6900490b52c5a6b6 (patch)
tree15408c31dfe1d556d0996ec30c153f21c4c45953
parentb3f80743cd1b9a15a8ee4d20c2a54c2f6cbcd13c (diff)
downloadopenembedded-core-contrib-rbt/linux.tar.gz
linux-yocto 4.4: enable overlayfsrbt/linux
So that iso can work well, otherwise the iso is readonly and there would be errors. The other way is aufs, but overlayfs is more pupolar and had been merged by kernel mainline. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.4.bb b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
index 5ab4da6d01..1d5b435a68 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
SRCREV_machine_qemux86-64 ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
SRCREV_machine_qemumips64 ?= "8b25338045fdb88a9cdff808003102643f03083e"
SRCREV_machine ?= "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
-SRCREV_meta ?= "32e84686fc87413612e108cc4ab0e7a0d21cb4fd"
+SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"
@@ -34,7 +34,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
# Functionality flags
-KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/overlayfs/overlayfs.scc"
KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"