aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-09-17 00:39:35 -0700
committerRobert Yang <liezhi.yang@windriver.com>2015-09-17 19:31:46 -0700
commit7fab77e612b616c57fa474334a2415477828fe58 (patch)
treee13f1c63d547853c7c1e6b223a9a777b8639af05
parentf0189829498e30231d826c9f55aad73e622d076e (diff)
downloadopenembedded-core-contrib-rbt/low_version.tar.gz
meta: fix build with gettext 0.16.1rbt/low_version
The gettext 0.16.1 doesn't install any m4 files to sysroot, please see the following commit: commit 9e10db5bdfe77c0ef2aff2f1cf89958b62c294a1 Author: Christopher Larson <kergoth@gmail.com> Date: Mon Mar 17 18:10:54 2014 +0000 gettext-0.16.1: kill target m4 macros from sysroot This is aim for using gettext-native's macros(gettext-native-0.19.4), but when we set: PREFERRED_VERSION_gettext = "0.16.1" And build the recipes like pcmanfm, we would get errors when do_configure: configure:5164: error: possibly undefined macro: AM_NLS This is because autotools_copy_aclocals doesn't copy the native macros for target unless they're direct dependencies. inherit gettext will fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-connectivity/connman/connman-gnome_0.7.bb2
-rw-r--r--meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb2
-rw-r--r--meta/recipes-gnome/libsecret/libsecret_0.18.2.bb2
-rw-r--r--meta/recipes-graphics/xorg-app/xwininfo_1.1.3.bb2
-rw-r--r--meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb2
-rw-r--r--meta/recipes-sato/pcmanfm/pcmanfm_1.2.3.bb2
-rw-r--r--meta/recipes-sato/puzzles/oh-puzzles_git.bb2
-rw-r--r--meta/recipes-support/atk/at-spi2-core_2.16.0.bb2
-rw-r--r--meta/recipes-support/libfm/libfm-extra_1.2.3.bb2
-rw-r--r--meta/recipes-support/libfm/libfm_1.2.3.bb2
-rw-r--r--meta/recipes-support/pinentry/pinentry_0.9.2.bb2
11 files changed, 12 insertions, 10 deletions
diff --git a/meta/recipes-connectivity/connman/connman-gnome_0.7.bb b/meta/recipes-connectivity/connman/connman-gnome_0.7.bb
index f5575d2938..d647874c07 100644
--- a/meta/recipes-connectivity/connman/connman-gnome_0.7.bb
+++ b/meta/recipes-connectivity/connman/connman-gnome_0.7.bb
@@ -19,7 +19,7 @@ SRC_URI = "git://github.com/connectivity/connman-gnome.git \
S = "${WORKDIR}/git"
-inherit autotools-brokensep gtk-icon-cache pkgconfig
+inherit autotools-brokensep gtk-icon-cache pkgconfig gettext
RDEPENDS_${PN} = "connman"
diff --git a/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb b/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
index c30454cab5..140589bac9 100644
--- a/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
+++ b/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
@@ -31,7 +31,7 @@ CFLAGS_prepend = "-DHAVE_ANIMATION "
RDEPENDS_${PN}-dev = ""
-inherit gnomebase
+inherit gnomebase gettext
GNOME_COMPRESS_TYPE="bz2"
python populate_packages_prepend() {
diff --git a/meta/recipes-gnome/libsecret/libsecret_0.18.2.bb b/meta/recipes-gnome/libsecret/libsecret_0.18.2.bb
index cebc83b574..0c9263b956 100644
--- a/meta/recipes-gnome/libsecret/libsecret_0.18.2.bb
+++ b/meta/recipes-gnome/libsecret/libsecret_0.18.2.bb
@@ -2,7 +2,7 @@ SUMMARY = "libsecret is a library for storing and retrieving passwords and other
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6"
-inherit gnomebase gtk-doc
+inherit gnomebase gtk-doc gettext
DEPENDS = "glib-2.0 libgcrypt"
diff --git a/meta/recipes-graphics/xorg-app/xwininfo_1.1.3.bb b/meta/recipes-graphics/xorg-app/xwininfo_1.1.3.bb
index 7a452410b7..b78439ee43 100644
--- a/meta/recipes-graphics/xorg-app/xwininfo_1.1.3.bb
+++ b/meta/recipes-graphics/xorg-app/xwininfo_1.1.3.bb
@@ -9,6 +9,8 @@ and a number of other items."
LIC_FILES_CHKSUM = "file://COPYING;md5=78976cd3115f6faf615accc4e094d90e"
DEPENDS += "libxext libxmu"
+inherit gettext
+
PE = "0"
SRC_URI[md5sum] = "b777bafb674555e48fd8437618270931"
diff --git a/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb b/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb
index f71514916b..d74afb6bdb 100644
--- a/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb
+++ b/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb
@@ -19,7 +19,7 @@ PR = "r2"
SRC_URI_append_poky = " file://owl-menu.patch;apply=yes "
-inherit autotools pkgconfig distro_features_check
+inherit autotools pkgconfig distro_features_check gettext
EXTRA_OECONF = " --enable-chooser --disable-emacs --disable-print"
diff --git a/meta/recipes-sato/pcmanfm/pcmanfm_1.2.3.bb b/meta/recipes-sato/pcmanfm/pcmanfm_1.2.3.bb
index 4467303f6e..8b589aeb6a 100644
--- a/meta/recipes-sato/pcmanfm/pcmanfm_1.2.3.bb
+++ b/meta/recipes-sato/pcmanfm/pcmanfm_1.2.3.bb
@@ -23,7 +23,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.xz \
SRC_URI[md5sum] = "c993402d407b0a3fc076f842ac1bc5c9"
SRC_URI[sha256sum] = "cfa8d82fc63be147045174bef074807e1e32ce8c6bf4dbd8fad49e260bcf6380"
-inherit autotools pkgconfig distro_features_check
+inherit autotools pkgconfig distro_features_check gettext
# The startup-notification requires x11 in DISTRO_FEATURES
REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta/recipes-sato/puzzles/oh-puzzles_git.bb b/meta/recipes-sato/puzzles/oh-puzzles_git.bb
index 36cd2cc7a2..13e0b802b7 100644
--- a/meta/recipes-sato/puzzles/oh-puzzles_git.bb
+++ b/meta/recipes-sato/puzzles/oh-puzzles_git.bb
@@ -25,7 +25,7 @@ SRC_URI_append_poky = " file://oh-puzzles-owl-menu.patch;striplevel=0 "
S = "${WORKDIR}/git"
-inherit autotools pkgconfig distro_features_check
+inherit autotools pkgconfig distro_features_check gettext
bindir = "/usr/games"
diff --git a/meta/recipes-support/atk/at-spi2-core_2.16.0.bb b/meta/recipes-support/atk/at-spi2-core_2.16.0.bb
index 933cbe70f7..fb759b50f4 100644
--- a/meta/recipes-support/atk/at-spi2-core_2.16.0.bb
+++ b/meta/recipes-support/atk/at-spi2-core_2.16.0.bb
@@ -13,7 +13,7 @@ SRC_URI[sha256sum] = "1c0b77fb8ce81abbf1d80c0afee9858b3f9229f673b7881995fe0fc16b
DEPENDS = "dbus glib-2.0 virtual/libx11 libxi libxtst intltool-native"
-inherit autotools gtk-doc pkgconfig distro_features_check
+inherit autotools gtk-doc pkgconfig distro_features_check gettext
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta/recipes-support/libfm/libfm-extra_1.2.3.bb b/meta/recipes-support/libfm/libfm-extra_1.2.3.bb
index 46d2d62b94..1c7ccf7f2d 100644
--- a/meta/recipes-support/libfm/libfm-extra_1.2.3.bb
+++ b/meta/recipes-support/libfm/libfm-extra_1.2.3.bb
@@ -20,6 +20,6 @@ EXTRA_OECONF = "--with-extra-only --with-gtk=no"
PR = "r1"
-inherit autotools pkgconfig gtk-doc
+inherit autotools pkgconfig gtk-doc gettext
do_configure[dirs] =+ "${S}/m4"
diff --git a/meta/recipes-support/libfm/libfm_1.2.3.bb b/meta/recipes-support/libfm/libfm_1.2.3.bb
index 629502f68f..f5be33bf9d 100644
--- a/meta/recipes-support/libfm/libfm_1.2.3.bb
+++ b/meta/recipes-support/libfm/libfm_1.2.3.bb
@@ -18,7 +18,7 @@ SRC_URI[sha256sum] = "c692f1624a4cbc8d1dd55f3b3f3369fbf5d26f63a916e2c295230b2344
PR = "r1"
-inherit autotools pkgconfig gtk-doc
+inherit autotools pkgconfig gtk-doc gettext
do_configure[dirs] =+ "${S}/m4"
diff --git a/meta/recipes-support/pinentry/pinentry_0.9.2.bb b/meta/recipes-support/pinentry/pinentry_0.9.2.bb
index c836ca4b86..cb01ad6407 100644
--- a/meta/recipes-support/pinentry/pinentry_0.9.2.bb
+++ b/meta/recipes-support/pinentry/pinentry_0.9.2.bb
@@ -8,7 +8,7 @@ HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
-inherit autotools
+inherit autotools gettext
SRC_URI = "ftp://ftp.gnupg.org/gcrypt/${BPN}/${BPN}-${PV}.tar.bz2"