aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-12-21 12:30:46 +0800
committerRobert Yang <liezhi.yang@windriver.com>2017-12-21 12:36:44 +0800
commit65382db74f44d0296de2ccc3e5f67bef740e8422 (patch)
tree1010f437eed4ea3c630cf7fd32f34f5178a3848e
parent978472c58629d1448399207873bbead96b27102e (diff)
downloadopenembedded-core-contrib-rbt/systemd_lz4.tar.gz
systemd: fix PACKAGECONFIG for lz4rbt/systemd_lz4
Fixed: MACHINE = "qemux86-64" PACKAGECONFIG_append_pn-systemd = "lz4" DISTRO_FEATURES_append = " systemd" DISTRO_FEATURES_BACKFILL_CONSIDERED += "sysvinit" VIRTUAL-RUNTIME_init_manager = "systemd" VIRTUAL-RUNTIME_initscripts = "systemd-compat-units" $ bitbake core-image-minimal $ runqemu tmp/deploy/images/qemux86-64/ nographic /sbin/init: error while loading shared libraries: liblz4.so.1: cannot open shared object file: No such file or directory Add lz4 to RDEPENDS to fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-core/systemd/systemd_234.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_234.bb b/meta/recipes-core/systemd/systemd_234.bb
index 778b8681a9..ed82c33791 100644
--- a/meta/recipes-core/systemd/systemd_234.bb
+++ b/meta/recipes-core/systemd/systemd_234.bb
@@ -122,7 +122,7 @@ PACKAGECONFIG[ldconfig] = "--enable-ldconfig,--disable-ldconfig"
PACKAGECONFIG[libidn] = "--enable-libidn,--disable-libidn,libidn"
PACKAGECONFIG[localed] = "--enable-localed,--disable-localed"
PACKAGECONFIG[logind] = "--enable-logind,--disable-logind"
-PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
+PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4,lz4"
PACKAGECONFIG[machined] = "--enable-machined,--disable-machined"
PACKAGECONFIG[manpages] = "--enable-manpages,--disable-manpages,libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
PACKAGECONFIG[microhttpd] = "--enable-microhttpd,--disable-microhttpd,libmicrohttpd"