summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/mc
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta-extras/packages/mc
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadopenembedded-core-contrib-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/mc')
-rw-r--r--meta-extras/packages/mc/mc_4.6.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-extras/packages/mc/mc_4.6.0.bb b/meta-extras/packages/mc/mc_4.6.0.bb
new file mode 100644
index 0000000000..6636c6747d
--- /dev/null
+++ b/meta-extras/packages/mc/mc_4.6.0.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "GNU Midnight Commander is a file \
+manager for free operating systems."
+HOMEPAGE = "http://www.ibiblio.org/mc/"
+LICENSE = "GPLv2"
+SECTION = "console/utils"
+PRIORITY = "optional"
+DEPENDS = "ncurses glib-2.0"
+RDEPENDS = "ncurses-terminfo"
+
+SRC_URI = "http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-${PV}.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-glibtest --without-x --without-samba \
+--without-nfs --without-gpm-mouse"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_install() {
+ cd src
+ oe_runmake 'DESTDIR=${D}' install
+ cd ../syntax
+ oe_runmake 'DESTDIR=${D}' install
+ cd ../po
+ oe_runmake 'DESTDIR=${D}' install
+ cd ../vfs
+ oe_runmake 'DESTDIR=${D}' install
+ cd ..
+}