summaryrefslogtreecommitdiffstats
path: root/meta/classes/archive-original-source.bbclass
diff options
context:
space:
mode:
authorXiaofeng Yan <xiaofeng.yan@windriver.com>2012-03-26 18:49:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-26 23:12:32 +0100
commitbc18dfdf42c8ece353a580671502ad79d37fa476 (patch)
treeecb4a479181ff3edf0507b8c5e45a84c02127151 /meta/classes/archive-original-source.bbclass
parent2fdc271887db8c0ef0641472d00e850e8b3caa19 (diff)
downloadopenembedded-core-contrib-bc18dfdf42c8ece353a580671502ad79d37fa476.tar.gz
archive-original-source.bbclass: Archive original source
This bbclass prepares for archiving original source. If original source is tarball, then copy this tarball to ${DEPLOY_DIR}/sources. If original source is dirctory, then archive this directory to tarball [YOCTO #1977] Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/archive-original-source.bbclass')
-rw-r--r--meta/classes/archive-original-source.bbclass14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/classes/archive-original-source.bbclass b/meta/classes/archive-original-source.bbclass
new file mode 100644
index 0000000000..b08553365c
--- /dev/null
+++ b/meta/classes/archive-original-source.bbclass
@@ -0,0 +1,14 @@
+# This file is for getting archiving packages with original sources(archive 's' after unpack stage),patches,logs(archive 'temp' after package_write_rpm),dump data and
+# creating diff file(get all environment variables and functions in building and mapping all content in 's' including patches to xxx.diff.gz.
+# All archived packages will be deployed in ${DEPLOY_DIR}/sources
+
+inherit archiver
+
+# Get original sources archiving package with patches
+do_unpack[postfuncs] += "do_archive_original_sources_patches "
+
+# Get archiving package with temp(logs) and scripts(.bb and inc files)
+do_package_write_rpm[prefuncs] += "do_archive_scripts_logs "
+
+# Get dump date and create diff file
+do_package_write_rpm[postfuncs] += "do_dumpdata_create_diff_gz "