summaryrefslogtreecommitdiffstats
path: root/meta/packages/oh
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-01-22 22:01:39 +0000
committerRichard Purdie <richard@openedhand.com>2008-01-22 22:01:39 +0000
commit8840cd25eeb52637ebc59ac859e627fc17f6243c (patch)
tree9dff2a854e02760e4b9f723bf7c031877ef9796a /meta/packages/oh
parente06f2c78392ec08913c6ac7c4d0fc24fedea3a5b (diff)
downloadopenembedded-core-contrib-8840cd25eeb52637ebc59ac859e627fc17f6243c.tar.gz
qemu-config: Add shutdown desktop file for qemu images
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3573 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/oh')
-rw-r--r--meta/packages/oh/qemu-config.bb12
-rw-r--r--meta/packages/oh/qemu-config/qemuarm/shutdown.desktop10
-rw-r--r--meta/packages/oh/qemu-config/shutdown.desktop10
-rw-r--r--meta/packages/oh/qemu-config/shutdown.pngbin0 -> 4823 bytes
4 files changed, 30 insertions, 2 deletions
diff --git a/meta/packages/oh/qemu-config.bb b/meta/packages/oh/qemu-config.bb
index 299aea2a76..d7c401eb2e 100644
--- a/meta/packages/oh/qemu-config.bb
+++ b/meta/packages/oh/qemu-config.bb
@@ -1,11 +1,13 @@
DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
LICENSE = "GPL"
RDEPENDS = "distcc task-poky-nfs-server fakeroot"
-PR = "r5"
+PR = "r6"
SRC_URI = "file://distcc.sh \
file://anjuta-remote-run \
- file://exports"
+ file://exports \
+ file://shutdown.desktop \
+ file://shutdown.png"
S = "${WORKDIR}"
@@ -20,4 +22,10 @@ do_install() {
install -d ${D}${bindir}
install -m 0755 anjuta-remote-run ${D}${bindir}/
+
+ install -d ${D}${datadir}/applications
+ install -m 0644 shutdown.desktop ${D}${datadir}/applications/
+
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 shutdown.png ${D}${datadir}/pixmaps/
}
diff --git a/meta/packages/oh/qemu-config/qemuarm/shutdown.desktop b/meta/packages/oh/qemu-config/qemuarm/shutdown.desktop
new file mode 100644
index 0000000000..2a42af5dcd
--- /dev/null
+++ b/meta/packages/oh/qemu-config/qemuarm/shutdown.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Shutdown
+Comment=Close down the machine safely
+Exec=reboot
+Icon=shutdown.png
+Terminal=false
+Categories=Utility;
+StartupNotify=true \ No newline at end of file
diff --git a/meta/packages/oh/qemu-config/shutdown.desktop b/meta/packages/oh/qemu-config/shutdown.desktop
new file mode 100644
index 0000000000..c1cb805694
--- /dev/null
+++ b/meta/packages/oh/qemu-config/shutdown.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Shutdown
+Comment=Close down the machine safely
+Exec=halt
+Icon=shutdown.png
+Terminal=false
+Categories=Utility;
+StartupNotify=true \ No newline at end of file
diff --git a/meta/packages/oh/qemu-config/shutdown.png b/meta/packages/oh/qemu-config/shutdown.png
new file mode 100644
index 0000000000..abf3f790dc
--- /dev/null
+++ b/meta/packages/oh/qemu-config/shutdown.png
Binary files differ