summaryrefslogtreecommitdiffstats
path: root/meta/packages/oh
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/oh
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadopenembedded-core-contrib-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/oh')
-rw-r--r--meta/packages/oh/usbinit.bb19
-rwxr-xr-xmeta/packages/oh/usbinit/usb-gether19
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/oh/usbinit.bb b/meta/packages/oh/usbinit.bb
new file mode 100644
index 0000000000..bfc8490dc1
--- /dev/null
+++ b/meta/packages/oh/usbinit.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Quick hack to start gadget Ethernet on the 770"
+LICENSE = "GPL"
+SECTION = "x11"
+PRIORITY = "optional"
+PR = "r0"
+
+SRC_URI = "file://usb-gether"
+S = ${WORKDIR}
+
+do_install() {
+ install -d ${D}/etc
+ install -d ${D}/etc/init.d
+ install usb-gether ${D}/etc/init.d
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "usb-gether"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
diff --git a/meta/packages/oh/usbinit/usb-gether b/meta/packages/oh/usbinit/usb-gether
new file mode 100755
index 0000000000..590e77b22a
--- /dev/null
+++ b/meta/packages/oh/usbinit/usb-gether
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+case "$1" in
+ start)
+ /sbin/depmod -a
+ /sbin/modprobe g_ether
+ ifconfig usb0 192.168.1.120
+ ;;
+
+ stop)
+
+ ;;
+
+ *)
+ echo "usage: $0 { start | stop }"
+ ;;
+esac
+
+exit 0