summaryrefslogtreecommitdiffstats
path: root/meta/packages/openssl/openssl-0.9.8o/shared-libs.patch
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-06-25 17:09:40 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-30 13:19:05 +0100
commitc4713d040a5b3ae90781cbb31a19868a1fa39f4e (patch)
tree066b4062f2a0646829254c5e1a7195e287a1c4a1 /meta/packages/openssl/openssl-0.9.8o/shared-libs.patch
parent7ec15f47750b2977972bbbbbe2aadf064c9671d5 (diff)
downloadopenembedded-core-contrib-c4713d040a5b3ae90781cbb31a19868a1fa39f4e.tar.gz
openssl: upgrade to version 0.9.8o
from 0.9.8g update bugtracker and license 1.0.0 and 1.0.0a are available, but introduce some interface changes. Stick on 0.9.8 versions for now for stability (0.9.8 branch is still updated for security fixes) changes: - add perl-native as build dependency - include /usr/lib/ssl/* in the package - break down debian.package into separate patches under directory debian. Original monolithic patch is >1000 lines, and not very maintainable. Verbatim copy the debian patches, among which two are not needed, but still included with apply=no to increase readability The new patches are ~700 lines. Most that was in the monolithic patch but not here have already been fixed in upstream. - fix-md5-x86_64.patch is in upstream and thus removed - rebase shared-libs.patch Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/openssl/openssl-0.9.8o/shared-libs.patch')
-rw-r--r--meta/packages/openssl/openssl-0.9.8o/shared-libs.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/packages/openssl/openssl-0.9.8o/shared-libs.patch b/meta/packages/openssl/openssl-0.9.8o/shared-libs.patch
new file mode 100644
index 0000000000..10d9146dc9
--- /dev/null
+++ b/meta/packages/openssl/openssl-0.9.8o/shared-libs.patch
@@ -0,0 +1,48 @@
+diff --git a/Makefile.org b/Makefile.org
+index e87d623..25ff367 100644
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -355,7 +355,7 @@ libcrypto$(SHLIB_EXT): libcrypto.a $(SHARED_FIPS)
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
+ if [ "$(FIPSCANLIB)" = "libfips" ]; then \
+ $(ARD) libcrypto.a fipscanister.o ; \
+- $(MAKE) SHLIBDIRS='crypto' SHLIBDEPS='-lfips' build-shared; \
++ $(MAKE) -e SHLIBDIRS='crypto' SHLIBDEPS='-lfips' build-shared; \
+ $(AR) libcrypto.a fips/fipscanister.o ; \
+ else \
+ if [ "$(FIPSCANLIB)" = "libcrypto" ]; then \
+@@ -373,7 +373,7 @@ libssl$(SHLIB_EXT): libcrypto$(SHLIB_EXT) libssl.a
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
+ shlibdeps=-lcrypto; \
+ [ "$(FIPSCANLIB)" = "libfips" ] && shlibdeps="$$shlibdeps -lfips"; \
+- $(MAKE) SHLIBDIRS=ssl SHLIBDEPS="$$shlibdeps" build-shared; \
++ $(MAKE) -e SHLIBDIRS=ssl SHLIBDEPS="$$shlibdeps" build-shared; \
+ else \
+ echo "There's no support for shared libraries on this platform" >&2 ; \
+ exit 1; \
+diff --git a/crypto/Makefile b/crypto/Makefile
+index 6557f2b..a69bf7c 100644
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -103,7 +103,7 @@ $(LIB): $(LIBOBJ)
+
+ shared: buildinf.h lib subdirs
+ if [ -n "$(SHARED_LIBS)" ]; then \
+- (cd ..; $(MAKE) $(SHARED_LIB)); \
++ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
+ fi
+
+ libs:
+diff --git a/ssl/Makefile b/ssl/Makefile
+index 5ac3507..77ea2bd 100644
+--- a/ssl/Makefile
++++ b/ssl/Makefile
+@@ -62,7 +62,7 @@ lib: $(LIBOBJ)
+
+ shared: lib
+ if [ -n "$(SHARED_LIBS)" ]; then \
+- (cd ..; $(MAKE) $(SHARED_LIB)); \
++ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
+ fi
+
+ files: