summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-03-01 21:07:52 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-02 18:41:31 +0000
commit5e280a4d6bf67c3b7d26c444bc52f25e63ae57a4 (patch)
treefd8338cfa83b67ccfbb37a2e7cb9b2b8d44d7725 /meta/recipes-core
parent31daf916d218d5e6e95bac857cbeb0d44901e4b3 (diff)
downloadopenembedded-core-contrib-5e280a4d6bf67c3b7d26c444bc52f25e63ae57a4.tar.gz
ovmf: upgrade 202111 -> 202202
0001-Fix-VLA-parameter-warning.patch removed since it's included in 202202 Changelog: ========= OvmfPkg Add new target for Cloud Hypervisor Add TDVF to OvmfPkg Add new APIs to UefiCpuPkg/UefiCpuLib Add AMD Secure Nested Paging Support Add SSDT PCI generator in DynamicTablesPkg Support ACPI 6.4 PPTT changes Add FdtHwInfoParser library Add DynamicPlatRepo library Make package and platform builds reproducible across source format changes Add Uncrustify CI Plugin Apply uncrustify changes to all package C and H files Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/ovmf/ovmf/0001-Fix-VLA-parameter-warning.patch51
-rw-r--r--meta/recipes-core/ovmf/ovmf_git.bb5
2 files changed, 2 insertions, 54 deletions
diff --git a/meta/recipes-core/ovmf/ovmf/0001-Fix-VLA-parameter-warning.patch b/meta/recipes-core/ovmf/ovmf/0001-Fix-VLA-parameter-warning.patch
deleted file mode 100644
index d658123b81..0000000000
--- a/meta/recipes-core/ovmf/ovmf/0001-Fix-VLA-parameter-warning.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 498627ebda6271b59920f43a0b9b6187edeb7b09 Mon Sep 17 00:00:00 2001
-From: Adrian Herrera <adr.her.arc.95@gmail.com>
-Date: Mon, 22 Mar 2021 21:06:47 +0000
-Subject: [PATCH] Fix VLA parameter warning
-
-Make VLA buffer types consistent in declarations and definitions.
-Resolves build crash when using -Werror due to "vla-parameter" warning.
-
-Upstream-Status: Submitted [https://github.com/google/brotli/pull/893]
-Signed-off-by: Adrian Herrera <adr.her.arc.95@gmail.com>
----
- c/dec/decode.c | 6 ++++--
- c/enc/encode.c | 5 +++--
- 2 files changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/BaseTools/Source/C/BrotliCompress/brotli/c/dec/decode.c b/BaseTools/Source/C/BrotliCompress/brotli/c/dec/decode.c
-index 114c505..bb6f1ab 100644
---- a/BaseTools/Source/C/BrotliCompress/brotli/c/dec/decode.c
-+++ b/BaseTools/Source/C/BrotliCompress/brotli/c/dec/decode.c
-@@ -2030,8 +2030,10 @@ static BROTLI_NOINLINE BrotliDecoderErrorCode SafeProcessCommands(
- }
-
- BrotliDecoderResult BrotliDecoderDecompress(
-- size_t encoded_size, const uint8_t* encoded_buffer, size_t* decoded_size,
-- uint8_t* decoded_buffer) {
-+ size_t encoded_size,
-+ const uint8_t encoded_buffer[BROTLI_ARRAY_PARAM(encoded_size)],
-+ size_t* decoded_size,
-+ uint8_t decoded_buffer[BROTLI_ARRAY_PARAM(*decoded_size)]) {
- BrotliDecoderState s;
- BrotliDecoderResult result;
- size_t total_out = 0;
-diff --git a/c/enc/encode.c b/c/enc/encode.c
-index 68548ef..ab0a490 100644
---- a/BaseTools/Source/C/BrotliCompress/brotli/c/enc/encode.c
-+++ c/BaseTools/Source/C/BrotliCompress/brotli/c/enc/encode.c
-@@ -1470,8 +1470,9 @@ static size_t MakeUncompressedStream(
-
- BROTLI_BOOL BrotliEncoderCompress(
- int quality, int lgwin, BrotliEncoderMode mode, size_t input_size,
-- const uint8_t* input_buffer, size_t* encoded_size,
-- uint8_t* encoded_buffer) {
-+ const uint8_t input_buffer[BROTLI_ARRAY_PARAM(input_size)],
-+ size_t* encoded_size,
-+ uint8_t encoded_buffer[BROTLI_ARRAY_PARAM(*encoded_size)]) {
- BrotliEncoderState* s;
- size_t out_size = *encoded_size;
- const uint8_t* input_start = input_buffer;
---
-2.31.1
-
diff --git a/meta/recipes-core/ovmf/ovmf_git.bb b/meta/recipes-core/ovmf/ovmf_git.bb
index 9db1514acc..b15d40eac8 100644
--- a/meta/recipes-core/ovmf/ovmf_git.bb
+++ b/meta/recipes-core/ovmf/ovmf_git.bb
@@ -21,11 +21,10 @@ SRC_URI = "gitsm://github.com/tianocore/edk2.git;branch=master;protocol=https \
file://0003-ovmf-Update-to-latest.patch \
file://0005-debug-prefix-map.patch \
file://0006-reproducible.patch \
- file://0001-Fix-VLA-parameter-warning.patch \
"
-PV = "edk2-stable202111"
-SRCREV = "bb1bba3d776733c41dbfa2d1dc0fe234819a79f2"
+PV = "edk2-stable202202"
+SRCREV = "b24306f15daa2ff8510b06702114724b33895d3c"
UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>edk2-stable.*)"
inherit deploy