summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-02-08 17:42:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-10 10:29:14 +0000
commitc659e7468686b8f6995cdc01dd0dbe0e84946bf6 (patch)
treee59e9fbcb1a07c762cef03b929b7ec6519c53807 /meta/recipes-core
parentc5142f867aaa3fb6fc134781e2e54ce10eabd530 (diff)
downloadopenembedded-core-contrib-c659e7468686b8f6995cdc01dd0dbe0e84946bf6.tar.gz
seatd: build systemd backend if DISTRO_FEATURE systemd is set
Add libsystemd dependency if we have systemd in DISTRO_FEATURES. This is needed to build the systemd backend. Projects that use seatd to hook into logind (e.g. wlroots) fail to properly login without it. Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/seatd/seatd_0.6.3.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-core/seatd/seatd_0.6.3.bb b/meta/recipes-core/seatd/seatd_0.6.3.bb
index 0e1a79dddf..abc8583087 100644
--- a/meta/recipes-core/seatd/seatd_0.6.3.bb
+++ b/meta/recipes-core/seatd/seatd_0.6.3.bb
@@ -13,9 +13,13 @@ S = "${WORKDIR}/git"
inherit meson pkgconfig update-rc.d
-PACKAGECONFIG ?= "libseat-builtin"
+PACKAGECONFIG ?= " \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+ libseat-builtin \
+"
PACKAGECONFIG[libseat-builtin] = "-Dlibseat-builtin=enabled,-Dlibseat-builtin=disabled"
+PACKAGECONFIG[systemd] = ",,systemd"
do_install:append() {
if [ "${VIRTUAL-RUNTIME_init_manager}" != "systemd" ]; then
@@ -26,4 +30,3 @@ do_install:append() {
INITSCRIPT_NAME = "seatd"
INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
INHIBIT_UPDATERCD_BBCLASS = "${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'systemd', '1', '', d)}"
-