summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-01-13 18:50:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-19 11:29:07 +0000
commit218dbe61917fbedbce45d55de63cce123773f721 (patch)
tree0a235ff64e49524c3b98183fa89b54d89738bdc7 /meta/recipes-devtools/autogen
parent7726884826332387180cd24ebe565cd13a193e13 (diff)
downloadopenembedded-core-contrib-218dbe61917fbedbce45d55de63cce123773f721.tar.gz
autogen-native: new recipe for grub-efi-native
grub-efi-native build is failing due to missing autogen command. Hence created this recipe. The newer versions of autogen 5.13 & 5.14 both are dumping core while building from source, so going back to the working 5.12 version. Also noticed that no distro vendor has picked up 5.13 or 5.14 versions of autogen yet. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/autogen')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.12.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.12.bb b/meta/recipes-devtools/autogen/autogen-native_5.12.bb
new file mode 100644
index 0000000000..cdf1ea9b19
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.12.bb
@@ -0,0 +1,24 @@
+SUMMARY = "AutoGen is a tool to manage programs that contain large amounts of repetitious text."
+DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
+ maintenance of programs that contain large amounts of repetitious text.\
+ It is especially valuable in programs that have several blocks of text\
+ that must be kept synchronized."
+HOMEPAGE = "http://www.gnu.org/software/autogen/"
+SECTION = "devel"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "6c6671b76021fb30dd43b0d5fdb7180b"
+SRC_URI[sha256sum] = "37e885d6c8a58f33ab198d38bb972fa4c14236f951d628161dde6e20527d0df2"
+
+PR = "r1"
+
+DEPENDS = "guile-native libtool-native libxml2-native"
+RDEPENDS = "automake pkgconfig"
+
+inherit autotools native
+
+# Following line will be needed for the non-native target recipe.
+#CFLAGS += "-L${STAGING_LIBDIR} -lguile-2.0 -lgc -pthread -I${STAGING_INCDIR}/guile/2.0 -I${STAGING_INCDIR}"