summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-15 23:42:00 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-21 12:13:21 +0100
commit4ef8960c8d2876914bb78cbdce5fae3c5297e942 (patch)
tree343555bb274288b1f84d3b814d6442de457f04e3 /meta/recipes-devtools/gcc
parent7f6883b225f9a0fdc44be2d1cb66ddc744174fbc (diff)
downloadopenembedded-core-contrib-4ef8960c8d2876914bb78cbdce5fae3c5297e942.tar.gz
gcc-cross-intermediate, gcc-crosssdk-intermediate: Remove
These recipes arent used anymore so delete them Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/gcc')
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross-intermediate.inc68
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross-intermediate_4.7.bb3
-rw-r--r--meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc9
-rw-r--r--meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb3
4 files changed, 0 insertions, 83 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-cross-intermediate.inc b/meta/recipes-devtools/gcc/gcc-cross-intermediate.inc
deleted file mode 100644
index e06926d6e1..0000000000
--- a/meta/recipes-devtools/gcc/gcc-cross-intermediate.inc
+++ /dev/null
@@ -1,68 +0,0 @@
-DEPENDS = "virtual/${TARGET_PREFIX}binutils ${NATIVEDEPS}"
-DEPENDS += "virtual/${TARGET_PREFIX}libc-initial"
-PROVIDES = "virtual/${TARGET_PREFIX}gcc-intermediate"
-PACKAGES = ""
-
-INHIBIT_DEFAULT_DEPS = "1"
-INHIBIT_AUTOTOOLS_DEPS = "1"
-
-CROSS_TARGET_SYS_DIR_append = ".${PN}"
-
-# This is intended to be a -very- basic config
-# sysroot is needed in case we use libc-initial
-#
-# Glibc won't compile with gold, and building glibc is the whole point of
-# this recipe. So we select ld.bfd explicitly here if gold is the distro's
-# preferred linker.
-EXTRA_OECONF = "--enable-shared \
- --disable-multilib \
- --disable-threads \
- --enable-languages=c \
- ${OPTSPACE} \
- --program-prefix=${TARGET_PREFIX} \
- --with-sysroot=${STAGING_DIR_TCBOOTSTRAP} \
- --with-build-sysroot=${STAGING_DIR_TCBOOTSTRAP} \
- ${EXTRA_OECONF_INTERMEDIATE} \
- ${EXTRA_OECONF_FPU} \
- ${@base_contains('DISTRO_FEATURES', 'ld-is-gold', '--with-ld=${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX}ld.bfd', '', d)}"
-
-do_populate_sysroot[sstate-inputdirs] = "${SYSROOT_DESTDIR}/${STAGING_DIR_HOST} ${SYSROOT_DESTDIR}/${STAGING_DIR_TARGET}/${target_base_libdir}"
-do_populate_sysroot[sstate-outputdirs] = "${STAGING_DIR_HOST} ${STAGING_DIR_TCBOOTSTRAP}/${target_base_libdir}"
-
-do_compile () {
- oe_runmake
-}
-
-do_install () {
- oe_runmake 'DESTDIR=${D}' install
- install -d ${D}${target_base_libdir}/
- osdir=`${D}${STAGING_BINDIR_TOOLCHAIN}.${PN}/${TARGET_PREFIX}gcc ${TARGET_CC_ARCH} -print-multi-os-directory`
- mv ${D}${exec_prefix}/${TARGET_SYS}/lib/$osdir/* ${D}${target_base_libdir}/
-
- # We don't really need this (here shares/ contains man/, info/, locale/).
- rm -rf ${D}${datadir}/
-
- # We use libiberty from binutils
- find ${D}${exec_prefix}/lib -name libiberty.a | xargs rm -f
- find ${D}${exec_prefix}/lib -name libiberty.h | xargs rm -f
-
- # Insert symlinks into libexec so when tools without a prefix are searched for, the correct ones are
- # found. These need to be relative paths so they work in different locations.
- dest=${D}${libexecdir}/gcc/${TARGET_SYS}/${BINV}/
- install -d $dest
- for t in ar as ld nm objcopy objdump ranlib strip g77 gcc cpp gfortran; do
- ln -sf ${BINRELPATH}/${TARGET_PREFIX}$t $dest$t
- done
-}
-
-#
-# Override the default sysroot staging copy since this won't look like a target system
-#
-sysroot_stage_all() {
- sysroot_stage_dir ${D} ${SYSROOT_DESTDIR}
- install -d ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${target_base_libdir}/
- install -d ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${target_libdir}/
- mv ${SYSROOT_DESTDIR}${target_base_libdir}/* ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${target_base_libdir}/ || true
- mv ${SYSROOT_DESTDIR}${target_libdir}/* ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${target_libdir}/ || true
-}
-
diff --git a/meta/recipes-devtools/gcc/gcc-cross-intermediate_4.7.bb b/meta/recipes-devtools/gcc/gcc-cross-intermediate_4.7.bb
deleted file mode 100644
index 69ae7f7bdb..0000000000
--- a/meta/recipes-devtools/gcc/gcc-cross-intermediate_4.7.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require recipes-devtools/gcc/gcc-cross_${PV}.bb
-require gcc-cross-intermediate.inc
-
diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc
deleted file mode 100644
index ed5d5e838d..0000000000
--- a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc
+++ /dev/null
@@ -1,9 +0,0 @@
-inherit crosssdk
-
-SYSTEMHEADERS = "${SDKPATHNATIVE}${prefix_nativesdk}/include"
-SYSTEMLIBS = "${SDKPATHNATIVE}${base_libdir_nativesdk}/"
-SYSTEMLIBS1 = "${SDKPATHNATIVE}${libdir_nativesdk}/"
-
-DEPENDS = "virtual/${TARGET_PREFIX}binutils-crosssdk gettext-native"
-DEPENDS += "virtual/${TARGET_PREFIX}libc-initial-nativesdk"
-PROVIDES = "virtual/${TARGET_PREFIX}gcc-intermediate-crosssdk"
diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb
deleted file mode 100644
index eacbc9ee2f..0000000000
--- a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require recipes-devtools/gcc/gcc-cross-intermediate_${PV}.bb
-require gcc-crosssdk-intermediate.inc
-EXTRA_OECONF += " --with-native-system-header-dir=${SYSTEMHEADERS} "