summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-12 17:29:40 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-12 17:29:40 +0000
commitfad5c8a33284902f66a05d1df5c7b7617eabfded (patch)
treecc98f2b1d35664ab822b93f33639802000c44a6d /meta/recipes-devtools/perl
parent17d13a5eefaea5c959b5980ce8b60f73165449c3 (diff)
downloadopenembedded-core-contrib-fad5c8a33284902f66a05d1df5c7b7617eabfded.tar.gz
perl-native: Wrap the perl binary and set the LIB directory correctly removing the need to hardcode the paths and rebuild it
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.12.2.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.12.2.bb b/meta/recipes-devtools/perl/perl-native_5.12.2.bb
index 824d5076f8..3fb22db442 100644
--- a/meta/recipes-devtools/perl/perl-native_5.12.2.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.12.2.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
@@ -88,6 +88,8 @@ do_install () {
thread.h warnings.h; do
install $i ${D}${libdir}/perl/${PV}/CORE
done
+
+ create_wrapper ${D}${bindir}/perl PERL5LIB=${STAGING_LIBDIR}/perl/5.12.2:${STAGING_LIBDIR}/perl/
}
do_install_append_nylon() {
# get rid of definitions not supported by the gcc version we use for nylon...
@@ -97,8 +99,3 @@ do_install_append_nylon() {
}
PARALLEL_MAKE = ""
-
-# Perl encodes the staging path into the perl binary so we have to depend on this
-# as part of the checksum for now
-HARDPATH := "${STAGING_BINDIR}"
-do_populate_sysroot[vardeps] += "HARDPATH"