summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.8.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2013-06-21 16:12:20 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-21 13:24:36 +0100
commit3ae2592b40900caaebe2452c875912f82f9e5200 (patch)
tree4ce1dee9f4a8772103e1b3b07edae3f555206109 /meta/recipes-devtools/strace/strace_4.8.bb
parentbdce39f22a0e8c8e1cf237322657220e4201077d (diff)
downloadopenembedded-core-contrib-3ae2592b40900caaebe2452c875912f82f9e5200.tar.gz
strace: update to 4.8
Update strace to 4.8: * Update License file. * Remove the backport patches which are already in version 4.8. * Add file git-version-gen from git repo. Without this file configure fails. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.8.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.8.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.8.bb b/meta/recipes-devtools/strace/strace_4.8.bb
new file mode 100644
index 0000000000..c1ffdd1270
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.8.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "strace is a system call tracing tool."
+HOMEPAGE = "http://strace.sourceforge.net"
+SECTION = "console/utils"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
+ file://git-version-gen"
+
+SRC_URI[md5sum] = "c575ef43829586801f514fd91bfe7575"
+SRC_URI[sha256sum] = "f492291f07a7c805c07a8395cce1ea054a6401ad414f4cc12185672215e1d7f8"
+inherit autotools
+
+export INCLUDES = "-I. -I./linux"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/git-version-gen ${S}
+}
+
+do_install_append() {
+ # We don't ship strace-graph here because it needs perl
+ rm ${D}${bindir}/strace-graph
+}
+
+BBCLASSEXTEND = "native"