summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-03-22 15:53:05 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-26 14:48:49 +0100
commit2f7ac32b57e047cdaf01e0b6f77509117dbbd14c (patch)
treeab1620aee6eb178f58797efa0cae6aba30e729d6 /meta/recipes-devtools
parent573949096d51bde4961b2301c20c966c324a66bd (diff)
downloadopenembedded-core-contrib-2f7ac32b57e047cdaf01e0b6f77509117dbbd14c.tar.gz
gcc-crosssdk-intermediate: Use --with-native-system-header-dir for 4.7
--with-native-system-header-dir is relative to sysroot which is what we want --with-headers is deprecated anyway Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc2
-rw-r--r--meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bb1
-rw-r--r--meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb1
3 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc
index 8f20d20156..ed5d5e838d 100644
--- a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc
+++ b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc
@@ -7,5 +7,3 @@ SYSTEMLIBS1 = "${SDKPATHNATIVE}${libdir_nativesdk}/"
DEPENDS = "virtual/${TARGET_PREFIX}binutils-crosssdk gettext-native"
DEPENDS += "virtual/${TARGET_PREFIX}libc-initial-nativesdk"
PROVIDES = "virtual/${TARGET_PREFIX}gcc-intermediate-crosssdk"
-
-EXTRA_OECONF += " --with-headers=${STAGING_DIR_TCBOOTSTRAP}${SYSTEMHEADERS} "
diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bb b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bb
index c7233af07b..3820cb670a 100644
--- a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bb
+++ b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bb
@@ -1,2 +1,3 @@
require recipes-devtools/gcc/gcc-cross-intermediate_${PV}.bb
require gcc-crosssdk-intermediate.inc
+EXTRA_OECONF += " --with-headers=${STAGING_DIR_TCBOOTSTRAP}${SYSTEMHEADERS} "
diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb
index 1aa588ac9f..32788988e8 100644
--- a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb
+++ b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb
@@ -1,2 +1,3 @@
require gcc-cross-intermediate_${PV}.bb
require gcc-crosssdk-intermediate.inc
+EXTRA_OECONF += " --with-native-system-header-dir=${SYSTEMHEADERS} "