summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_5.12.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-07-03 00:19:21 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-05 10:59:24 +0100
commite6f456bf661fdc9586edbbc8be71aabbaf2e3531 (patch)
treec8601b9aa7ff6dc3663b36f109515495345253f7 /meta/recipes-extended/man-pages/man-pages_5.12.bb
parent8f4eaa7bb9f14b90ce13f17807938ada4d88e6bc (diff)
downloadopenembedded-core-contrib-e6f456bf661fdc9586edbbc8be71aabbaf2e3531.tar.gz
man-pages: upgrade 5.11 -> 5.12
License-Update: installation instructions Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_5.12.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_5.12.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_5.12.bb b/meta/recipes-extended/man-pages/man-pages_5.12.bb
new file mode 100644
index 0000000000..a5b2c30305
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_5.12.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Linux man-pages"
+DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
+SECTION = "console/utils"
+HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
+LICENSE = "GPLv2+"
+
+LIC_FILES_CHKSUM = "file://README;md5=92cd5ee2e0b35d782817e7e277b6ce4b"
+SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/${BP}.tar.gz"
+
+SRC_URI[sha256sum] = "2684d42ab53184d7607105834e277577daa7e854cdce0d4aacf9f7ad8437c7ce"
+
+inherit manpages
+
+MAN_PKG = "${PN}"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[manpages] = ""
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ oe_runmake install prefix=${prefix} DESTDIR=${D}
+}
+
+# Only deliveres man-pages so FILES_${PN} gets everything
+FILES_${PN}-doc = ""
+FILES_${PN} = "${mandir}/*"
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "passwd.5 getspnam.3 crypt.3"
+ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
+ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"
+ALTERNATIVE_LINK_NAME[crypt.3] = "${mandir}/man3/crypt.3"