summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/glslang/glslang_11.2.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2021-02-27 12:48:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-01 11:12:12 +0000
commit21e853a6c6d6629567f88d4ad9f12b76a876d3cb (patch)
tree63cd93a760030cad088a6d42b8419f190dbaa28b /meta/recipes-graphics/glslang/glslang_11.2.0.bb
parent9c36b944502c146e4160fb9363ec8dfeac608cc2 (diff)
downloadopenembedded-core-contrib-21e853a6c6d6629567f88d4ad9f12b76a876d3cb.tar.gz
glslang: upgrade 11.1.0 -> 11.2.0
Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/glslang/glslang_11.2.0.bb')
-rw-r--r--meta/recipes-graphics/glslang/glslang_11.2.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-graphics/glslang/glslang_11.2.0.bb b/meta/recipes-graphics/glslang/glslang_11.2.0.bb
new file mode 100644
index 0000000000..902f7345f5
--- /dev/null
+++ b/meta/recipes-graphics/glslang/glslang_11.2.0.bb
@@ -0,0 +1,31 @@
+SUMMARY = "OpenGL / OpenGL ES Reference Compiler"
+DESCRIPTION = "Glslang is the official reference compiler front end for the \
+OpenGL ES and OpenGL shading languages. It implements a strict interpretation \
+of the specifications for these languages. It is open and free for anyone to use, \
+either from a command line or programmatically."
+SECTION = "graphics"
+HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
+LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c5ce49c0456e9b413b98a4368c378229"
+
+SRCREV = "5421877c380d5f92c1965c7a94620dac861297dd"
+SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https \
+ file://0001-generate-glslang-pkg-config.patch"
+UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$"
+S = "${WORKDIR}/git"
+
+inherit cmake python3native
+
+EXTRA_OECMAKE = " \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_SHARED_LIBS=ON \
+ -DENABLE_PCH=OFF \
+ -DENABLE_CTEST=OFF \
+ -DBUILD_EXTERNAL=OFF \
+"
+
+SOLIBSDEV = "glslang.so"
+# all the other libraries are unversioned, so pack it on PN
+FILES_${PN} += "${libdir}/*.so"
+
+BBCLASSEXTEND = "native nativesdk"