summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/glslang/glslang_11.7.0.bb
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2021-11-14 20:26:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-15 12:53:35 +0000
commit70df8eca65a702f3d78ff1a683d21fc826163173 (patch)
tree109f6bf01cd2560430f7ca0f09f22eb28387722d /meta/recipes-graphics/glslang/glslang_11.7.0.bb
parentc0c414b2c27c4b0fe99a3c322d06e41a9030ab64 (diff)
downloadopenembedded-core-contrib-70df8eca65a702f3d78ff1a683d21fc826163173.tar.gz
glslang: upgrade 11.6.0 -> 11.7.0
Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/glslang/glslang_11.7.0.bb')
-rw-r--r--meta/recipes-graphics/glslang/glslang_11.7.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-graphics/glslang/glslang_11.7.0.bb b/meta/recipes-graphics/glslang/glslang_11.7.0.bb
new file mode 100644
index 0000000000..0b4bf21bca
--- /dev/null
+++ b/meta/recipes-graphics/glslang/glslang_11.7.0.bb
@@ -0,0 +1,31 @@
+SUMMARY = "OpenGL / OpenGL ES Reference Compiler"
+DESCRIPTION = "Glslang is the official reference compiler front end for the \
+OpenGL ES and OpenGL shading languages. It implements a strict interpretation \
+of the specifications for these languages. It is open and free for anyone to use, \
+either from a command line or programmatically."
+SECTION = "graphics"
+HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
+LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c5ce49c0456e9b413b98a4368c378229"
+
+SRCREV = "925503088e2bcd76921b1e102c37fc320bace254"
+SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=master \
+ file://0001-generate-glslang-pkg-config.patch"
+UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$"
+S = "${WORKDIR}/git"
+
+inherit cmake python3native
+
+EXTRA_OECMAKE = " \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_SHARED_LIBS=ON \
+ -DENABLE_PCH=OFF \
+ -DENABLE_CTEST=OFF \
+ -DBUILD_EXTERNAL=OFF \
+"
+
+SOLIBSDEV = "glslang.so"
+# all the other libraries are unversioned, so pack it on PN
+FILES:${PN} += "${libdir}/*.so"
+
+BBCLASSEXTEND = "native nativesdk"